Frustrated with Support

We got our GF over a week and a half ago and I’m still not able to use it from my own desktop. My husband set it up, then added me as a user. You can clearly see on his account that I’ve been invited, but when I go to the app, I get a “no Glowforge page”. The invite email I got just links me to the homepage. I contacted support and got this answer:

“Thank you for reaching out. I’m so sorry for the trouble. Unfortunately, I can’t help you with another persons account. Would you have your husband reach out and let us know what he’d like to do?”

He contacted them about the problem and got this response:

“Thank you for reaching out. It looks like your wife does have an account. She can login at with her email and click “no password.” If she has any trouble, please don’t hesitate to let us know. Thank you for letting us know about the email, I’ve let the team know so we can investigate.”

Uhh… Maybe she didn’t read the email fully? That answer isn’t even related to what he asked and each response takes 3-4 days. Any suggestions? I’ve tried logging in with his account on my computer, and that doesn’t work. A different browser doesn’t work either.


Have you logged into with your account?

Yes, same problem.

Thank you for your patience. I’m so sorry for the frustration. I’ve verified that you have been added to your husband’s machine.

I’m going to close this topic. If you have any other questions, please feel free to start a new topic.

1 Like