Fusion DXF and Inkscape And GFUI


#1

Hello Fellow Forgers!

I have been busy forging away since FiendFyre arrived a few weeks ago. You know, - working on things like kerf and all that. My focus has been designing in Fusion 360 and inkscape. I decided to try and start a project in fusion then adjust for kerf in inkscape just to get a feel how things work. (I assure you, it will be one special Sharpie Holder when it is done!) I got the kerf part (Or at least I think I do - believe it or not) by making the adjustments that @jules wrote in her tutorial. That was great! I then hit a snag. The sketches I laid out in Fusion 360 came into inkscape with all the right dimension. When I place the design into the GFUI and cut the pieces the whole design was smaller. For example, the length of my object in fusion was 120mm. It went into inkscape (where i translated it into inches) and measured 4.79ish inches. It came out of the glow forge at about 113 mm. I looked around the forums for such a discussion and there was some dpi and accuracy discussion, but that did not seem quite right, although I am not that familiar with all the details of either of the apps so I could be wrong. The reduction in size seems consistent across the whole model because the notches all snap fit nicely (still surprised at the kerf success!!)). Is there a fusion inscapes GFUI golden ratio I am missing? Any help is greatly appreciated!!

Matthew


OpenSCAD units do not come out right on Glowforge
#2

This is almost always due to an SVG export setting mismatch. ‘Responsive’ must be off/unchecked. May have a different name in inkscape.


#3

Hmmm…cant find a “responsive” setting in Inkscape. As you suggest, likely called something else. Will keep looking.


#4

As far as I know there is no option like this in inkscape. The default save settings work as is. Did you save as a plain svg?


#5

Yes. Saved as a plain SVG.


#6

That is very strange then. I use inkscape exclusively for designs and have never had a design not come out the size I specified. Do you have it set so that the stroke width is not part of the calculation of size?


#7

Sorry, I’m not an inkscape user. Perhaps this would be helpful…


#8

My other inkscape designs work, too. Not sure if I changed something accidentally. Geometric bounding box is checked. I think that is correct and I don’t think that would have an impact although it might. I can try the visual bounding box, instead.


#9

No don’t change it. Geometric is what you want. Yeah I didn’t think it was the culprit but thought I’d throw it out there just to at least check. If you reopen the plain svg saved file in inkscape does it show up correctly?


#10

I closed and re-opened it. It seems to open fine. I think something else is up. As I think about it, why would the height of the notches be ok?I set the notches to be ⅛ inch in fusion. They stayed the same through the GF because the kerf worked. Why didn’t they get too thin? May start from the drawing board. Perhaps a GF fusion lover will come by and comment.


#11

Jus did a 5x5 square. It was short, too. Hmmm…


#12

Yeah this baffles me. Sorry I couldn’t be of more help. Good luck!


#13

Can you upload an example SVG file?


#14

I sure can. Here are 2. The first square 127mmx127mm I started in fusion, saved as dxf. Put it in Inkscape. Changed to a path, saved as plain svg. Put it into the GFUI. It printed a 119x119mm square. The second is the same sized square started in inkscape. The GFUI cut it 127x127 minus a little for kerf. square%20inkscape


#15

square%20inkscape


#16

What do the dimensions say when you select the object in Inkscape?

I’m curious because ultimately I’ll be wanting to bring parts from f360 designs over to the GF.

I made a 5mm registration circles in Inkscape this morning, just to help align some parts on the material. While that job was printing, I saw your thread, so I made the same 5mm circles in F360, exported to DXF.

There are a couple of options when opening with Inkscape - scale manually, or “based on file” - I tried both ways, different results, manually 1:1, they came out at 0.5mm, “from file”, they were 6.15mm.


#17

When I click on the fusion created square the dimensions are correct. 127x127. Where are the scale options? I don’t see those when I open the dxf from inkscape.


#18

I think it only let me upload 1. Newbie, I guess.


#19

What version are you using? Whether I right-click and select Open in Inkscape, or from Inkscape select File/Open, either way it pops up a dialog asking how I’d like to scale the file.

To be more specific, when you said you click on the fusion created square, you mean inside inkscape? If that is the case, then it’s not a DXF-SVG issue, but I’ve never had an inkscape-created plain SVG not cut accurately from the GFUI.


#20

56
This is at the dialog box I see. I unblock the first and scale to 1. Everything I start in fusion is the right scale in Inkscape. But exporting to SVG or uploading to GFUI changes something.