Fusion DXF and Inkscape And GFUI

Yah. My guess is the document size needs to be 12x20 in Inkscape before saving out as SVG. Fusion-DXF-Inkscape-GFUI (or Affinity Designer) is my daily workflow.

1 Like

I just spent an hour struggling with essentially the same problem. In my case, I don’t know what program generated the DXF file I was working with, but OPENING it in inkscape, saving it back out as an SVG (tried both inkscape and plain) after making some edits, and then sending it to the GF resulted in a mis-scaled item … off by several mm.

FWIW, the solution for me was to IMPORT it into inkscape. After this, all my final dimensions matched the inkscape numbers.

1 Like

Thanks for the tip! These things can certainly be a struggle for sure. I am updating the software and will IMPORT. I will let everyone know the results. Fingers crossed!

Thanks for this! The inkscape website is confusing, although I am sure these open source builds have lots of issues beyond the website. Will update ASAP!

After a bit of a slog I am happy to report that my DXF from Fusion made it into Inkscape, was successfully turned into a plain SVG, successfully loaded into the GFUI and was cut to the correct scale.

To make this happen I updated Inkscape and set a default template to a 508x304.8mm I am not sure what fixed it exactly, but after a some playing it worked. There are some quirks though. When I IMPORT the DXF and choose “Scale from file” it comes into Inkscape huge! When I import the DXFand choose manual scale with a factor of 1, it comes into in Inkscape correctly. I can then make modifications and upload.

When I OPEN the DXF file and choose “scale from file” it also comes in huge and it defaults back to pixels. It does not open my template. If I choose to scale manually the size is correct but my template is ignored. If I simply click open the DXF file to open it, the same thing happens. Not sure why the template is ignored. Not sure why the file has the wrong scale in it. When I click "new"or open Inkscape to start the default template opens. Its using OPEN that seems to be the issue.

Needless to say, with import and manual scale, I have a working workflow, even if there are some quirks. And for all the work - a sharpie holder! OOOH 21 Sharpies! YES!


Fantastic! (And great holder! I need to work one up for several dozen.) :grinning:

1 Like

That matches my experience. My guess was that either I misunderstood what “scale from file” was trying to communicate or the Fusion 360 DXF doesn’t specify. But I forgot to go back and figure it out since manual scale = 1 gave me the result I was looking for.

1 Like

There seems to always be quirks. Such as software!

Many many thanks to all those who helped here!

@MakerMatthew Your project turned out great! I’m going to close this topic – please post a new one if you run into anything else.