Getting double pass on these cuts


#1

I’m doing a cut and a score and for some reason it’s doing 2 passes on these lines. No idea why.

Here’s the PDF that I drop in to Glowforge…
cutscore.pdf (40.5 KB)

Those lines are each set to “0.001mm” in Illustrator.

The outer line is the cut and the inner line is a score. It does a double pass on both despite the “# of passes” definitely being set to 1.

It’s actually proof grade material and I’m just using the default Proofgrade Cut/Score settings.


#2

When you get double cuts it generally means there are duplicate lines in the file.


#3

Yeah, have checked in to that and as far as I can tell that’s definitely not the case. Though, I attached the PDF file so someone can tell me if that’s not true.


#4

I opened your file, released the compound path, released the clipping mask, separated the layers, deleted the filled layers, added strokes to two of the layers, and ended with the two separate lines. Kept them similar colors for you, and should work now.

cutscore.zip (715 Bytes)

What software are you running to create these? I would generally use the shape tool/rectangle tool in Illustrator to make something like this without issue.


#5

Sorry, just saw you said you used Illustrator, guess my question is what process did you use?


#6

In my Illustrator file each of those lines is a rounded rectangle with a transparent fill and a .001mm stroke.

Should I be doing something other than that?


#7

That’s what they are, but you’ve somehow created two on top of each other.


#8

I’m wondering now if this is somehow a byproduct of my choosing “PDF” instead of “SVG” as the export option because opening the PDF export vs the SVG export definitely has a different file/path/fill structure.

Hmmm…


#9

It could have something to do with the pdf file, I’m not entirely sure. I’m not a wiz at this sort of stuff, I just thought I would take a crack at your file to see if I could figure it out.

Maybe someone comes along and can explain it better than me, but yeah, I would use the rounded rectangle tool to create one, then either create a second using the same method, or going to object -> path -> offset path to get a precise difference.


#10

I notice your paths are slightly different sizes (3.65" and 3.6499"), maybe the pdf export has created a path for the fill and a path for the stroke?

Or maybe you used “Offset path” in Illustrator, which creates a second path, and the original path was never deleted (which can be very difficult to see if the offset difference was something as small as .001").


#11

I’ve dumbed it down even more to just a single line “cut” SVG and it’s still double passing. :frowning:

Here’s a zip containing both the Illustrator file and the exported SVG…

cuts.zip (307.6 KB)


#12

Definitely something funky going on. The SVG file is now a weird fill (zoom way in on the top left corner).


#13

Sweet beard of zeus I figured it out.

My stroke alignment was set to “Inside”. Changed to “Center” and all was right in the world.


#14

Noticed that as well, was still showing some weird visual issues when reopening the SVG, but the path at least looked correct. Curious why your paths are set so small? I noticed using something a little thicker seemed to fix the issue as well.


#15

I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at support@glowforge.com. We’re here to help!


#16