GF engraving lines NOT in design

and then in the SAME line it’s engraving (when it’s NOT supposed to) it WONT engrave where it is supposed to! It’s inverting that specific line. VERY frustrating.

It is NOT an open path. It is a shape, cut out of another shape, done in Illustrator CC. SO the cut out part should NOT be engraved, and 99% is correctly not engraved. But for some reason, it engraves through all the shapes (text in this case) yet on that very same line, it doesn’t engrave (where it should)…

I thought, maybe I bumped the GF mid-engrave. Maybe something is stuck in the tracks/rails/lenses/etc. NOPE. The GF things there is something there that isn’t, in the design. I design in Adobe Illustrator CC, then Export As - SVG, then upload that SVG file to the GF universe. That’s what I’ve been doing for months now, please don’t argue over if that’s correct or not, It has been working GREAT.

Ive now wasted 3 hours, and about $100 in material trying to fix this for an order I need to get out tomorrow morning (it’s 945pm now). I’m pissed. Every once in a while my GF does some stupid thing like this, then for no reason, it is all better. Sometimes files won’t upload. Sometimes the focus won’t work. Other times other issues. Getting frustrated trying to run a small business with the GF as my main tool and it’s moody. Scares me to think I plan on buying an additional one.

These are after I’ve changed the design a few times. it’s a font, turned into shapes, then using shape builder tool, REMOVED from the background. So the background should get engraved, the text should NOT be.

PLEASE HELP.

It would be hard to identify without looking at the file. One thing I’ve noticed though when using the Shape Builder tool in AI…it’s very easy to think you’ve got it locked down, but there can be a “not completely closed” shape that will yield some unexpected results once in a while.

I’ve usually found that for complex shape building (like subtracting text) it’s a better idea to convert the text to paths (Rt. click/Create Outline) then convert it to a Compound Path (select and CTRL+8) then use the Compound Path with the Minus Front tool. It tends to give more consistent results.

Not sure if that’s what’s going on there, but you might want to try it and see how it does.

4 Likes

If you need to get it done, Object > Rasterize 600 ppi.

4 Likes

I might have to try that.

I found a work around if you can call it that. A DIFFERENT font.

Same exact process, but I used a different font, created outlines, shape builder tool to remove it from the background, bam… worked like a charm. Only, it’s NOT my customers requested font. So NOW my super awesome hi-tech laser is picky on fonts? Come on…

yeah i guess that would work too, just hate having to work around an issue that just randomly appears for no reason… as if my machine and the programs running it are some cheap chinese copier.

It’s likely not the laser, but the font. Fonts are built for print, not subtracting from other shapes. Many of them are in horrible shape, with open paths, excess nodes and crossed paths. Usually it’s more trouble than it’s worth to try to repair them before using them.

If you want to engrave an unknown font without a lot of additional work and without the problems, just do what JB suggested and rasterize it. You’ll get consistent results every time with a raster engrave, because the GF software doesn’t have to try to interpret bad paths.

8 Likes

I’m so sorry to hear that you’ve hit this snag, and I apologize for the frustration this may have caused. As @jbmanning5 and @Jules outlined, the trouble may be related to the components inside of the file. I’m glad to hear that you were able to find a small work around.

Would it be possible to obtain a copy of the file? We’d be happy to take a look.

Thanks for all the help and support everyone! Definitely makes me happy to be a part of this community.

Here’s a recreation of the problem.

Blue rectangle. Type some font. Create outlines. Select all shapes. Shape builder tool, subtract letters from blue background/rectangle.

GF engraves random lines into the letters that are not there. Same exact spot every time in each trial. No matter where I place the material in the bed. Like its in the design, but I know it’s not.

Attached is the .ai file. (Are we not allowed to upload multiple files? It won’t load the .svg file.

Untitled-1.ai (154.0 KB) !

Untitled-1

I’m surprised you are having as much luck as you are with it… when I broke apart the compound path to see what was going on… well, here’s an example on the counter of the R. I think there are like 21 copies or so there that I dragged out from the one line.

I can get to the same conclusion by just double-clicking into the compound path, rather than breaking it apart.

image

1 Like

Oh, yeah, opened in Inkscape, the file is a mess - all of the letters are that way.
image
I have no idea how AI works, but enough people here use it to tell you what you’re doing wrong.

Font has nothing to do with it. There is no concept of fonts in GF - it doesn’t process text, only paths.

I’m sorry about the ongoing trouble. The things that @jbmanning5 & @eflyguy mentioned in their most recent posts are correct. A large number of overlapping vector objects in the design might be leading to the print results you’re getting on your unit. One option would be to try and remove all of the duplicate shapes and paths.

If the entire design is to be engraved, something else you could try would be to convert the design to a bitmap image in Illustrator before saving it as an SVG. In Illustrator, this process is called rasterizing. We have a new guide on our support website which details how to do this in both Illustrator and Inkscape. Here is a link: Rasterize Objects

Will you please let us know if this resolves the issue?

1 Like

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.