GF files "Rendering your design..."

Anyone else having problems downloading GF files?
Personal files load OK but not GF files.
Just “Rendering your design…”

1 Like

I just tried several Glowforge files and they all opened ok. Maybe try a different browser and see if you have better luck.

1 Like

I tried that and the old standby, turned the computer off and back on.
Nothing wrong that a good nights sleep won’t cure LOL

3 Likes

Had the same issue almost all day. Appears everything is working now. Dealt with chat support and they couldn’t fix anything when it wasn’t working. Kind of screwed up my whole day.

Hello! @lcronkite It sounds like you were able to get back to printing. Let me know if you are still running into trouble and I will be more than happy to assist. Thank you!

Must have been a glitch in the system. Working fine all day today.

1 Like

I am also having issues with “rending your design”. The design just shows up blank.

Thank you for your patience while the team looked into this.

I’m glad you were able to open your designs just fine now. In case anyone else is viewing this thread with the same issue, we’ve made an update that should resolve this issue for you. Could you please try opening the affected designs again, and start a new thread if you’re still running into trouble?