Glow forge jumps off tracks and doesn’t cut through

It arrived a little over two weeks ago and I wasn’t able to use it much at first due to timing of a major event I was hosting. But what little I have done, at least half of my cuts have not gone through, even on proofgrade draftboard. I thought I must be doing something wrong, so I gave up on it till I had more time to devote. Fast forward to today. I’ve tried some 1/8” Purple Heart and that was a pain. So I went back to draft board and it still doesn’t cut through. Plus is jumps off the track half the time, wasting any progress it made.

It jumps off the track all the time. I tried calibrating the camera 3 times and all three times, the print head jumped off the tracks causing me to waste two entire pieceS of draft board as well as my time. I’ve got Zeiss wipes and have cleaned the lens… though it shouldn’t be dirty since I’ve hardly used the unit.

We have made sure the surface is level as well. There’s nothing on the tracks either.

It jumps the tracks around 8 minutes into the video.

1 Like

Have you checked the belt tension on the left and right hand of the machine? the right side could be loose and slipping as it tries to home.

Instructions below


I will try this.

The box it came in was pretty damaged. The lid sits flush on the left side when I put it down. On the right, there is a little give when I put the lid down.

Even with the test pattern during camera calibration, , I could see the engraving on the left side was very dark and clean and it gets lighter and spotty on the right side.

I wonder if the whole unit got dropped and misaligned during shipment…

I think you should double check the placement of your 12x20 sheet of material. It appears to me that you have it too far forward as if it is butting up against the door. In my machine, the honeycomb part of the tray is not against the door. Also, double check to make sure the honeycomb tray is seated in the four dimples and that there is no debris in the dimples.

Perhaps the angle of the camera. The tray is settled in the dimple’s and the instructions for Camera calibration said to put the draft board all the way at the front of the honeycomb tray. It’s settled completely flat in the tray.

1 Like

The tension is fine on both sides. The tray is settled in perfectly. Things cut ONLY on the left side. The whole unit jumps off the tracks periodically. It will not calibrate. I tested the gift of good measure and it didn’t cut through.

The test pattern it prints (before jumping off the tracks, rendering a wasted piece of draft board) is fine on the left and then faint on the right.

I know that it is a holiday and I do see staff responding to other threads but yet no one has commented in here. I am technically the owner of the GF but only because I haven’t transferred to my wife @katiemoritz1 who is trying to get this resolved. It appears just reading through other comments that we have two major issues.

  1. Not cutting through and I’m guessing it was the update that went out because the first few cuts of “gift of goods” worked perfectly and based on other users’ comments the same thing is happening for them and it might only just be the Pro.

  2. The laser arm just keeps jumping the track. When you try and do a calibration which is something GF has out there it can’t even complete the 40 min calibration. It dies / jumps the track 20 mins in and you waste an entire board.

We are glad to be GF owners and are very frustrated that it appears we got a 6k lemon. Once again I get it (holiday weekend/pandemic) that support is dealing with a lot of other folks as well. It is just right now a large paperweight in our basement.

Support works business days & hours, US Pacific time, although often you’ll see them pop in outside those days/times. Technically, you shouldn’t expect a response until tomorrow.

It sounds like you have two separate issues. If you’ve followed all the steps on the official troubleshooting page for failing to cut thru, then that alone will likely mean the machine will need to be replaced.

1 Like

@eflyguy Yup that was our take as well it is just dishearting when you finally get the product, have some time to start really putting it through the paces and it is not working. :cry:

They have over 26,000 of these out there now - it sucks when you’re the one with an issue, but have faith the machines are generally very reliable. Dan posted in his latest update that the average number of prints per machine per day was 2 last month. That’s an amazing number…

I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.

1 Like