Glowforge Bed not refreshing regardless of what material I use

Glowforge bed is not refreshing. It is stuck on an old material and will not update. I have tried restarting my computer, clearing all cache, turning my machine on and off, restarting my wifi. Has anyone else had this problem and can anyone help? Have tried support but they’re offline =(

I’m actually having the exact same problem and just came here to ask fr advise, I’ve restarted my computer as well as glowforge, cleared my history as well as cache and still the same.

Hopefully someone from glowforge support will come back to us. Hope we can resolve it soon!

Same… and it was working fine 10 min ago.

I have also just encountered this issue.

ok so its clearly a glowforge issue or bug of some sort, I guess we can all have a sigh of relief since were all having the same issue and just wait until glowforge fixes it unfortunately


Yes! and it doesn’t cut it scores

We are having the same problem as well. I have tried the same thing as everyone else with no success.

I’m having the same issue with one of my two Glowforge machines. One is fine and the other is not updating the image. I tried the … menu option to refresh bed image and focus, no luck.

Same here- tried all the troubleshooting steps and image is not refreshing. We just used it this morning and now nothing.

same issue here

mines up and running now hopefully everyone will be as well soon… much love <3


Thank you for letting us know about the issue with the image on screen in the Glowforge App not updating. The trouble has now been resolved.

Please refresh your browser and the bed image should update. If you are still having trouble after receiving this message, please let me know.

On behalf of the whole team here at Glowforge, I apologize for the inconvenience.

Kind regards,