Glowforge does not work for the start

I bought my wife a Glowforge plus for Xmas. I have spent most of Xmas day trying to get it to work.
I have followed the tutorials to no avail.
the printer head moves around like it’s printing but no laser is visible. it says it printed but of course it didn’t.

very disappointed that this very expensive item is broken from the get go.
I know nothing about this machine except frustration.

It appears now that I have to figure out some way to get it fixed. having to ship back a huge item like this is BS.


Sorry to hear you’re having some trouble. If you want our help we’re going to need some additional information.

It appears you were able to connect to the internet without issue. Good job!
What design were attempting to cut?
What material were you attempting to cut?
If it was Proofgrade material, did the interface recognize it as the correct material?
Did you adjust any settings to speed/power?


I used proof grade material. the machine recognized the material. I was printing as a test the “good measure” thing they recommend you print when you get the machine.

the machine makes a ton of noise, the head moves around like it’s printing but the laser never is visible. I don’t think the laser works.

The fan that runs is also extremely noisy. clanks and grinds away.

machine appears defective

1 Like

However unlikely, that’s certainly possible!

Should sound, perhaps, like the steady tone/volume of a vacuum cleaner or hair dryer.

There should be nothing really like that.

I wouldn’t suggest you attempt to cut anything at this time. But when you turn the machine on you should hear a light sound, the arm and head should move with a… sort of 1980’s sci-fi robot mechanical sound. It should sit under the camera for a moment, then return to the back-left. Is that what happens?

Have you reached out to Support about this? There are logs they can examine that may shed some light.


One thing I suggest you can check…when you have the print ready to set up, double check the power setting on the left side. Even though you are using proofgrade settings, sometimes the power will revert to “1” which is not enough to do anything. When that happens, it will do what you’ve described…go through all the motions of cutting/engraving etc. but not actually do anything to the material. I truly think it will be something easy to figure out and fix…and I hope nothing more.


I checked the power settings. turned it to 80 percent. still no Laser.

I tried to upload a video. no luck.

no response from tech support either

You can add a link to a video on YouTube, if you like. Try to be patient…support will for sure contact you, but they can be a bit slow. This is a holiday weekend too, so there’s that.

Make sure that the item has focus (3 dots in the top right) set and is within range of the laser. I’ve had that happen to me with wrong placement and settings.

1 Like

Please do this. Might help us help you.

1 Like

I got a hold of tech support. after a few things they had me try they authorized a return and replacement.

My replacement arrived yesterday and seams to be working as advertised.

thanks for the help and suggestions., now time to learn this machine.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.