Glowforge Ghosted Me!

Today I fired up the forge after a day off and within a minute or so of engraving, the laser just ghosted me. Gone. The unit acted as if it were still engraving but it was not. I cancelled the print (which seemed to take longer than normal for the machine to actually stop working) and tried again, several times. A few times I would get the yellow light AFTER cancelling the print. I live in Hawaii so the temperature is not as issue. But just incase we re-cleaned all fans, vents etc. And while we were at it we cleaned the lens, mirror and everything in between. Many more tries later and still no laser beam, but did also get the purple light a few times. I’m not sure what that one even means. Did my laser tube just die on me?? :frowning: I’ve had my basic for approximately 1 year 5 months-ish. Help! I sent an email to support but I’ve heard horror stories on response times and well,
I’m still praying there’s something I haven’t checked yet and it’s an easy fix seeing as how I have orders to make.

Oh, and yes, the power is set to FULL so it’s not an issue of that.


Check the connection of the white cable to the head carriage.

1 Like

Checked, doesn’t seem to be causing any problem.

Also, here are pictures of the common issues I saw on previous threads:

Yellow light is usually either temperature or white cable. Check the connection at the other end too, and also take a look at the cable to see if it’s got any wear on it from rubbing on the gantry.

The other thing that can make the laser not fire is duplicate lines in your artwork, so it might be worthwhile to try cutting the Gift of Good Measure, just to rule that out.

Good luck!


Hi @ashley.collins0513. I’m sorry to hear that you’ve been running into some trouble with your Glowforge’s laser stopping mid-print. Hi I see you already emailed us about this and we’re working on it there, so I’m going to close this topic to consolidate any communications and troubleshooting. Thank you!