Glowforge intermittent freezing

So I have been struggling with the frozen Glowforge problem. I turn it on and watch it go through the motions, but once it gets to “Centering” it just does nothing at all. If i open the lid and gently apply pressure I can feel that the stepper motors are engaged, and I can hear the focus mechanics process, but no gantry movement happens.
Here is what I have tried:

  1. power on/off
  2. reset wifi
  3. leave lid open and turn on, wait for a while
  4. used a hot-spot instead of my local wifi
  5. restarted router
  6. restarted computer
  7. tried an alternate computer

So far nothing works, permanently. That’s the weird thing, after banging my head against the wall for hours it will suddenly bumble to life, then work fine for 45 minutes or so. Then - dead. Can you look into my log files and help me assess what to do next?

mine just started doing the same thing this evening. I give up. Im going to bed and will try again in the morning, I pray this is not a long term, send it somewhere issue.

Hello @Aaron - I’m sorry to hear you’ve been having so much trouble with your printer being stuck on centering. Thank you for reaching out, and sharing the steps you’'ve already provided, it really helps narrow down our troubleshooting.

Since you’ve covered many of the basics, I’ve extracted the logs from your Glowforge and looked at the trouble you’ve been experiencing. The issues you’re seeing might be caused by a poor connection with the cables on your lid. Please follow the steps below to check the lid connections:

  1. Turn off your unit.

  2. Open the lid.

  3. Using both hands, gently roll the laser arm to the front of the unit.

  4. There are 5 clips pictured below. Check each one to ensure it is closed. The clip should lie flat, and you shouldn’t be able to flip it in any direction.

  1. If any of the clips are open, please take a photo and attach it to your reply. Don’t try to adjust or reseat the cable until reaching back out to us.

Please let me know if you have any questions.

1 Like

All clips appear to be intact, and are firm to gentle prying with my fingernail. Here are some representative pictures.


Hmm, update again. After monkeying with the ribbon cable connections it is working again, for now. I assume that a good cleaning of these connections is the solution.

Hi @Aaron - I’m glad to hear you’ve managed to get back up and running, that’s great! I’ll go ahead and close this topic for now, but please feel free to reach out with another post or email us at support@glowforge.com if anything should change, and we’ll make sure you’re taken care of!

Well, it appears that I was wrong about it being a simple cleaning. After some uneventful projects it has started to act up again. Cleaning, wiggling cables, on and off, all to no clear solution.

After multiple startup>focusing>scanning(but very brief, like maybe one second)>centering… I will occasionally get perhaps one solid gantry movement, then a freeze on centering again.

After a dozen of these, which vary between a movement or two, then a no movement, then back to moving, etc. I do finally get it working. And when it runs, it runs well.

The confusing part is that it runs well. If it was a short or a dirty connection I would expect spotty performance during a burn, but that never happens.

I have determined that I get the most radical change when I just concentrate on fiddling with the actual lens head unit itself, and that ribbon cable. Trouble is that there is so little mechanical connections there that I can’t figure out what is the exact issue.

If I were to take a guess at it I would say that it is more software related than hardware, due to the weird inconsistent behavior (broken hardware is always broken, not inconsistent) and the fact that when it runs it runs well. Maybe I need to have my firmware reflashed? I don’t know, just grasping at straws here.

For the moment I have it working again and I am continuing with my projects, but that’s only because I spent an hour trying to get it working.

I think that I may have finally located the problem. It seems to be related to the cable connection from the camera to the LED strip. Although I have gently detached and cleaned it already, it seems that if the Glowforge is stuck I can open the lid, press with reasonable pressure upon that connection alone, close the lid and it will continue.

I suspect some magnified inspection and further cleaning with bright lights for assistance may help. For now I am calling this issue closed.