Glowforge is not working "Unexpected Error"

Glowforge is saying “Unexpected Error” every time I try to use it.

Before you ask:
Yes I tried turning it off and on again
Yes I tried using several different files
Yes I tried different computers
Yes I tried logging off and back on
Yes I tried using a different browser

Not to mention the Error Code it was giving me before was 502 meaning it was server side and not client.

Also, maintenance is not scheduled for another 12 hours.
Edit: The maintenance already happened. Just makes this problem even worse.

Bump :see_no_evil:

Hey there! I’m just commenting on your post because I am having a similar problem today! I got a 502 error, and now the app page is loading and I can see my design laid over yesterday’s scanned image of the Glowforge bed, but my Glowforge is showing as offline.
I also did all the yeses you list here, zsmith. The only thing I can’t do is reboot my wifi, because I’m in a lab in a University and I don’t have access to turning off wifi/don’t want to incur the wrath of everyone on campus if I turned the wifi off and back on again.

I encountered the same error at the end of a job this morning, and then the 502 on the screen, so suspected server issue, but I was lucky I guess that refreshing the window got it up again (though as full start up in the library & GFUI was empty). But I was able to run another job I needed to get done before I needed to shut down & pack up to go to a show!

It wouldn’t have helped, 5xx html errors are server side. I only did it because I know I would get 100 replies saying to do that.

Since wifi can often be an issue–not always due to the GF itself, but sharing the network with others–is there any way you can get the the IT guys to set the lab up on a different network & channel than the rest of the campus?

When I had Offline issue last year, changing my network channel from 1 to 9 & again to 11 has (knock on wood) stopped me from having that issue again.

Yeah, not sure how changing the channel helped but the problem is that it’s a server side error. My internet connection isn’t the problem

It’s possible - I would still be very interested to know what is causing the problem today though, since I haven’t encountered this problem before in the 4 months we’ve been using our device.
Zsmith, I feel and share your frustration! I have a group of high school students coming into the lab in ten minutes, and I know they were hoping to see the machine operating. This machine is so reliable, and I hate for kids to see all the cool stuff we’ve made with it and to have to tell them it’s out of commission today.

Today’s issue with the 502 error is server related issue.

But as I noted in regard to “Offline”, not all cases are due to the GF. Please search the threads for “offline” and you’ll find numerous actions and solutions that are related to the user’s network.

And often if you rely on someone else to set up your network, they’ll set up 5gHz or use the “band steering” that is supposed to let the device choose 2.4 or 5. The GF must have dedicated 2.4. I have two networks set up in my house, 2.4 for the GF, and 5 for anything else.

Dude, I can’t even make it to offline

I really, really hope the server issue gets resolved quickly so you can get on line again!! But it may not be GF itself–I just connected/loaded a job without issue again.

Once (when figuring out “offline” issue) I did a “trace” and found my signal bounced 22 times from my house to Glowforge, including Amsterdam & then Mountain View CA & finally back up to Seattle–and I’m only 20 miles from GF! Alas if there’s an issue at any one of those points, it’s not good. In theory the cloud is supposed to mean any issue in one place, other systems take up the job…

I’m sorry you ran into trouble. We were experiencing a system outage at the time of your report and I believe this caused the issues you were seeing. We’ve resolved the cause of the outage and you should be good to go now. If you’re using the App, you may need to refresh your browser. Will you please let us know if you’re now able to connect and print as expected?

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email