Glowforge no longer working - filled shape is open

I tried cutting multiple designs tonight that used to work fine 2 days ago. Now, I get the following popup in the bottom right after I press print:


It feels like some update was pushed to the GF cloud that is breaking things for me!

These designs have 100s of shapes. I don’t want to go through them to find any that may or may not be open. Can we revert the updates back to when it was working!


That would be an update on the cloud end/UI so I doubt there will be any reverting. Are you using AI or Inkscape? If AI, I can tell you how to select the paths that are open so that they can be fixed.

Reverting would be going backwards in the sense of, I can’t tell you how many posts have been made here about vector shapes not seeming to engrave properly because the software tries to close the path itself.


I am using Inkscape. I looked online for a tutorial on how to find open paths, but my quick google did not turn up anything.

My opinion is that if they uploaded a change that breaks existing designs, they should revert back to an earlier version. I have probably dozens of designs that I’m going to have to go back and check. And some of them are pretty complex.

I’m also selling some of my designs. I test it out and make sure it works for me before I sell them. If I then sell it, and the cloud changes and the designs no longer work, then my reputation can take a big hit, since people will assume I sold them a bad design. This is a HUGE issue for me.

I understand that there may be lots of questions about open paths. I would be ok with a new warning that says “you have open paths, your print may not come out as expected”. But not with something that blocks the print completely. Especially if it worked last week.

I need to know that designs that works now will work in the future if I’m selling them to others.


I’m so sorry for the frustration.

If you can share the file you’re having trouble with, we’d be happy to take a look.

You can post it here, or email it to us at

Can you tell me the approximate time on Nov 20th the same file worked?

Hi @pip

Thank you for helping me. I’d like to know how to make the files work again. But mostly I would prefer if the GF just worked again on those files.

Has there been a change in the GF cloud that is now more restrictive of file shapes? I’ve sold some of my designs on Etsy. I made sure they worked before selling them. If you made the GF more restrictive, I can fix my own files to pass that restrictions. But I can’t go fix the ones that I’ve already sold to others.

If a restriction was added, can we remove it, and just give a warning instead?



1 Like

Thank you for emailing us the files you’ve been having an issue with. Of the files you sent us, the only file that encountered a “Filled shape is open” error was trees_times6.svg. From the logs, there have only ever been 3 attempts to print this specific file, all on 11/21/2018. There are no records that this file was printed successfully previously.

The other file that you sent encountered a different error, that your unit was offline when you attempted to print that design. The logs do indicate that you were able to print that design successfully on 11/18/2018. It looks like your Glowforge came back online after that print failed so you should be able to print that design again.

If you have difficulties with any other designs that you’ve printed previously please let us know and we’ll be happy to investigate but it appears that this issue is only affecting a new file and not any files you’ve printed previously.


I am now able to print the 2nd file that I sent (the Ranger one). I have not tried the trees_times6.svg yet.

But I am sure that I tried to print it yesterday and got the “filled shape is open” error. I’m pretty sure my GF was not offline (or at least did not say it was offline), since I was able to press the print button. I tried it multiple times, each time getting more concerned about the error. And I’m sure the error I saw was the filled shape one. I still had it open with that error showing 10 minutes ago when I tried to print it again just now. I think there was a problem with the UI. Perhaps the GF was offline, but was showing online. You may want to investigate further. I really don’t think it was a user error in this case. (God knows I’m the first to admit it when I think I’m the cause of the error).

The trees one, I had never printed before, but I did print the same design that is in it before in another file (trees2.svg). I simply copied and pasted that design 6 times in the new file. I don’t think I changed anything else.

So the question remains: How do I fix the trees_times6.svg file? Is there a tutorial on finding open paths somewhere?

I’m pleased to know that the designs that were working are working again. Thank you for looking into it. I really appreciate the quick turn-around.


One workaround would be to convert your design to an engraving, with these instructions.

To convert to an engraving in Inkscape:

  • Open your file in Inkscape
  • Select the part of your drawing that you had previously scored
  • Choose Edit > Make a Bitmap Copy
  • Inkscape will make a bitmap copy underneath the original artwork
  • Click the top shape to select it, then press the delete key
  • You’ll be left with the bitmap copy
  • Save your file as an Inkscape SVG
  • Return to and upload your new file

In Adobe Illustrator:

  • Open your file in Illustrator
  • Select the part of your drawing that was set to score
  • Choose Effect > Rasterize
  • Select “Grayscale” in the Color Model drop down list
  • Choose “Transparent” under Background
  • Press “OK”
  • Save your file as an SVG
  • Return to and upload your new file

Another option would be to try posting in Tips-and-Tricks, or Everything-Else categories and ask how other people in the community handle these and if they have any advice or workflows they could share.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email