Glowforge PRO not turning on

My Glowforge is not turning on. I have unplugged the cable at both ends and plugged back in. I have tried different outlets and nothing. I have plugged in other devices and the outlet works fine. I have tried a different cable from my printer and it still won’t work. I’ve checked all connections suggested on other threads and everything is fine. I bought my Glowforge in 2019 almost 2 years ago exactly. I’ve never had a problem with it until today when it just won’t work. Help! I need it for almost all of my products and I have a show this weekend.

You’ve probably checked, but the Pro also has a little switch in the back near the plugin… It’s like a circuit breaker. If that tripped you might need to reset it (push it in I think… I have a plus so I am going on memory alone here) and then you can power it back on again.


Yeah, I have checked that and It’s solidly in there. Thanks though!

Well hopefully support will be along shortly with some more insight.

It is NOT a “circuit breaker” and the machine will power on just fine with it removed.

It simply halts the machine immediately, or prevents it from operating if not already. Just like opening the lid except the gantry will freeze. Machine has to be rebooted to resume operation.


Ah. Gotcha. Knowing is half the battle and all that. :slight_smile:

Hi @srobrien1130 - I’m sorry to hear you’ve run into this trouble. I’m swinging by as I’d just come across your email ticket and sent along some additional steps to triple check.

Could you please check your email for me and let me know if those steps help? If we’ve already done the homework of things like checking another outlet, checking that the cable is plugged in, etc, our best route may be to look into getting your printer replaced.

Since it’s possible a replacement is needed I’m going to go ahead and close this topic and we can finish up in that email thread.