Glowforge reading error, shut power down

my glow forge uploads items intermittently. it keeps saying there’s an error, turn machine off and refresh browser. ive logged in and out of the app, turn machine on and off several times, still nothing. could the server be down? I checked my internet connection, is good as well.


I just had this error!

I am unable to upload any designs new, or ones I’ve done before.

I am able to print from items that are already upload.

This seems like a service error on the servers.

Glowforge support! Please help! I gotta fill this order :smiley:


1 Like

I’m also having this same problem.
I was able to upload a new file and cut earlier, but now I can’t upload any new files.

I can load file that are already on the dashboard.
I cannot upload any files, or I get this same error. It even errors if I try to reupload the same file I cut earlier.

I’ve refreshed browser multiple times, and a glowforge restart also didn’t help.

1 Like


Following to see if they will respond to your post!

Same. There are multiple threads about this issue this morning.

they better respond, I haven’t had this thing 1 week. im still in the “ship it back” stages

This started happening to me about 20mins ago. I’ve cleared my cache and such, rebooted laptop, unplugged Glowforge, and also tried different browser and nothing. Following to see if there is a solution.

I can upload some images from the new design create dashboard. but nothing from inside the actual print set up platform.

Same - this is very frustrating thinking it is my machine when it is actually the servers. Status page needs monitoring and updated.

1 Like

@ty397 Thank you so much for reaching out to us regarding this. We did have an issue which impacted your ability to upload, which should now be resolved.

Everyone, please try your upload again. If there is an issue, please send us an email or create your own forum post and we’ll make sure that we get this taken care of for you