Glowforge stuck on "Centering"

I’ve done all the troubleshooting for this problem I can find online, I’ve thoroughly cleaned the lenses of the machine and everything else I can reach by hand. I’ve restarted everything, wifi, comptuer, GF. The machine whirs up when I turn it on, then there’s a series of clicks that I think are a servo coming up, then the button flashes with a final high-pitched squeal. The head doesn’t try to seek the camera like it normally does, and the webapp reads “centering” until I refresh the page and it immediately reads “Scanning”. So I think the web app isn’t sure what the machine is getting stuck on. I feel like its having some sort of whatever the equivalent of a BIOS issue is, maybe it partially downloaded an update. Also maybe the servos finally got sick of all the crud building up in them? Its really hard to tell, the machine doesn’t give you a lot of info of what it’s doing. Has anyone experienced anything similar?

Have you tried cleaning the lid camera, and also cleaning the top of the laser head where the Glowforge logo is?

Yeah I’ve given everything a cleaning. The head doesn’t seem to even want to try to center either, normally get gets ‘lost’ looking for the camera if the cameras being dirty is the issue but it won’t start that process. Turning it on makes it whir to life like its supposed to, the button flashes, but that’s as far as it gets.

I’ve taken a video of the startup process. The machine just idles after the point where the video cuts.

There is a big window next to the GF. The bright light can confuse the processing when looking for the head. Might not be your issue but it does happen.

Do you always start it with the head in the center like that? Try moving the head to the upper lefthand corner over the grid and see if it can find the head…that clicking always happens on my machine while the head is parked there. Then it moves out to the center under the lid camera for the first picture.

I’ve tried to start the machine with the head in a number of locations. In the past manually centering the head has been a workaround for this problem. In all cases the head does not attempt to seek the camera at all, remaining where ever it was when the machine powers on.

I’ve waited until nighttime and the problem persists.

The issues you’re seeing might be caused by a poor connection with the cables on your lid. Please follow the steps below to check the lid connections:

  1. Turn off your unit.
  2. Open the lid.
  3. Using both hands, gently roll the laser arm to the front of the unit.
  4. There are 5 clips pictured below. Check each one to ensure it is closed. The clip should lie flat, and you shouldn’t be able to flip it in any direction.
  5. If any of the clips are open, ensure the cable is inserted straight into the clip and close the clip.
  6. If any of the cables are misaligned in the clip, take a photo of the clip and cable and send it to me so I can take a look before you proceed. Do not try to adjust or reseat the cable.
  7. Close the lid.
  8. Turn your unit back on and wait for it to calibrate.

Let me know how it goes!

Don’t know whether your issue will turn out to be one of those connectors, but a tip for everyone. Be very careful when cleaning the inside lid glass with a rag. It’s very easy to catch on one of those connectors.


I am having the same exact problem right now with my glowforge. And I refreshed the app to make sure that it changed from “Centering” to “Scanning” and it did! All my cable connections look good and secure, so I’m at a loss as to what to do…

You need to start your own thread to be sure that it gets seen and has a ticket assigned to it. Add-on posts are very easy for them to miss but they look for new posts. :slightly_smiling_face:

I’m having the exact same problem. Exactly as you describe it and have attempted the fixes that you’ve described.

The GF started having this problem on 12/20

please update with any further information when its available.


It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email