Glowforge won’t turn on

I used my glowforge this morning and it worked perfectly . I’ve gone to turn it on just now and it won’t turn on . There’s nothing at all. I’ve tried a different cable and I’ve tried different sockets so I know it has to be the glowforge :frowning: any ideas a ?

What model of machine do you have. You said you tried different outlets and plugs but did you try another thing like a lamp on those outlets to see if there is power?

1 Like

If you have the pro, there’s a “staple” thing in the back near the power switch I believe (I have the plus). Make sure that’s pushed all the way in and try it again.

1 Like

Thanks for your fast replies . It’s the basic model and I’ve tried the cable on a lamp and the lamp works :frowning: so I really don’t know what to do

You’ve opened a support ticket by posting here, so they’ll be along soon to help you out!

The interlock doesn’t cut power. It suspends machine operation just like having the lid open.


I’m so sorry to hear that you’re running into trouble. I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.