Gradient Printing get's messed up if not 90°


#1

All,
I tried to reach Glowforge support - but got told that I have to ask the question here :unamused:
I’d like to cut out some pieces with gradients. I did some pretesting with a regular square and a simple 90° Gradient. That worked fine. But now I’d like one with a 60° Gradient. Unfortunately this doesn’t work - the gradients are just messed up.
I attached for your reference the two files.Gardient Test.pdf (7.2 KB)
Kerzen Kirche-Turm1.pdf (10.4 KB)

What can I do that the 60° Gradient works too?


#2

these look like the same file to me.


#3

oops - thank you! I uploaded the correct file now…


#4

Haven’t looked at it yet, but all vector gradients have to be rasterized before they can be used for variable depth engraving. (Did you rasterize them first?)

Okay, never mind, i see that one of them has been rasterized. Try saving it as an SVG with the raster image Embedded.


#5

the gradients are rasterized, but everything is buried in clip-paths and clip-groups. I’ve pulled the bits out of the clip pile and running a test now.


#6

Hi Jules,
thank you for your input - yes I did rasterise them before. :blush:


#7

what program are you using to create these?


#8

Affinity Designer…


#9

Yeah, I was working on it:

Kerzen SVG.zip (8.2 KB)

Like @jbv said…I just removed the Clip paths and saved it as an SVG instead of a PDF.

When you try to engrave that for depth, in order to have a 3D Engrave option, you will need to choose either Draftboard or one of the Hardwoods or Acrylic. Otherwise you will have to override the Photo Engrave setting to get a Variable Engrave in the Manual settings.

But it opened fine. :slightly_smiling_face:


#10

@All - wow that was indeed a very fast problem solving session!! Thank you SOOOO much!!


#11

The gradients engraved as expected. More passes would be needed to get them deeper.

one thing I noticed was that the stroke applied to the cut lines was pretty thick, and the gradients only go to the edge of the stroke color, not all the way to the centerline of the stroke, so there is a tiny lip all the way around.


#12

öhm… (strange german noise…)
How do I remove “clip-paths” and “clip-groups”. To me everything looks nice and cleaned up in Affinity… :open_mouth:


#13

#14

Chuckle! That might be a glitch added by Illustrator when we open AffinityD files in there…I’ve noticed them being created on files that originated in other software (and even newer versions of Adobe Illustrator) before. (No way to tell which ones it’s going to wind up on without knowing where the file originated, so now I just tend to delete them.)

Affinity Designer uses clip paths a lot in it’s subtractive processing, where Illustrator and Inkscape use actual subtraction. Can’t explain it other than to say I think the Glowforge interface knows how to deal with them by now, and you can just safely ignore them when you are preparing your files, as long as you remember to rasterize your gradients.

If it does continue to be a problem, you might want to try out Inkscape for conversion before you save the SVG.


#15

I guess I found the solution in Affinity Designer: In the export dialog there is a “more” button - choose “svg flatten”.
That did the trick for me… :blush:


#16

I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at support@glowforge.com. We’re here to help!


#17