GUI Changes dimension randomly

I am having issues with the Glowforge UI, when changing dimensions under the ruler tool. I was trying to change the width and height of an object. I would enter in a value for either the width or height and instead of keeping the value I entered, it would change it to some random value. Sometimes it was higher, sometimes it was lower. For example: I entered 10.95 for the height, and it changed it to 11.037. What the heck is going on here??

Additionally how does it decide how what will allow before it changes to “No Artwork”? I wanted to score a line the entire width and height. If the object is larger, it changes to “No Artwork”. It would be nice if it would just score the line to the end, regardless if the object went outside the bounds. But I noticed as I was trying to find the max number, sometimes it would allow 10.95 and other times it would change to “No Artwork”. Is there some way to see what the max values are without having to enter in a bunch of numbers using trial and error?

Welcome to the forum.
Do you have the aspect ratio unlocked? I cannot imagine any other way the dimensions don’t stay at the size you input.

The maximum printable area is about 10.95" by 19.5" If, however, you don’t place the file just perfectly on the bed, you will get the “No Artwork” As far as I know, you can set the dimensions to whatever size you want, but if the file is larger than the printable area or placed too high on the bed,you will get the No Artwork notice. It is best to place your material as close to the front of the machine as possible and against the right tray edge to maximize the printable area.

That does sound like the aspect ratio is locked. To unlock it, you click on the link and turn it off. (or shift). Additionally, the engrave area is smaller. There’s usually a light gray box where you can see the size that will need to fit.

No the aspect ratio is not locked.

Here is a quick GIF of it. In this example I typed 19.895 for the width and when I clicked off, it changed 19.903. Also sometimes it takes the number fine, but when I click print it changes the values and says I can’t print. This UI is one of the most frustrating I have used.

I’m not sure if this is what is impacting it, but do you see the blue dot in the upper lefthand corner on the Positioning grid? Switch that to the center slot and see if it makes that stop. (It’s weird, for sure.)

1 Like

I mean it doesn’t appear to do it anymore if the center one is selected, but it also changes the location. What I mean by that is that if I change the width value it doesn’t appear to change the dimension equally from left and right side. What I was trying to do is figure out the total area of the bed for reference. So I had set the top left dot so it would fix that corner to top left. Then as I change the height and width it still be set in the top left corner. If it is set to the center, I have to change the width, then reset where it is located if I wanted in the top left corner. But at least it isn’t changing my W and H values. :roll_eyes:

I’m not sure it’s set up to do what you’re trying to do with it, but it’s an interesting conundrum…

Maybe if you set the X position location to 0, instead of 0.01, and then tried it it would work. (And I can’t tell what the Y position location is, but set that to 0 as well, and set the position indicator to the upper lefthand slot where you had it.)

See if that works. (I can’t imagine why it’s making the value larger.)

Update:
Annnnnnd…because I like riddles, I worked out the settings. The numbers for position and size do change…it’s a little bit odd. (Support might need to look into it at some point.) This is what worked on my machine to maximize the bed area and allow cuts. (Keep in mind, engraves have a smaller working area, and that might be why it’s not set up to do this this way.)

Oh, and we do have to take it out from 0/0 in order for the design to hit the bed and cut…0.01 and 0.01 work just fine. That’s also a little odd, but maybe they have a little bit of leeway factored in.

2 Likes

Thanks for the help. The reason I had my positions at 0.01 (on both X and Y) was because if I left them at 0 I got the “No Artwork” regardless of the size of the object. If I moved it to 0.01 then I could print. I am a software engineer by day, and this issue screams a software “rounding error” bug to me. But without knowing what it’s trying to do behind the scenes I don’t know.

For what I’m trying to do is cut out a bajillion little rectangles for “reed blocks” that are used inside concertinas/accordions. So I am trying to get as many of the rectangles in one go as I can and maximize the material. Without knowing pretty close to where my outer limits are, it makes it difficult. That’s why I was trying to test the boundaries. It may just not be designed to do it since it uses a camera vs limit switches like my cnc.

Thanks again for your help.

Happy to help. Hopefully that will let you maximize your cuts.

1 Like

Does it do that if you use mm instead of inches? I believe GF’s native units are metric but they translate everything to imperial. The translations would create variance in the numbers.

2 Likes

I found my boundaries by using artwork of a single line - place one at top, bottom, left and right, nudge each with keyboard arrows to the last position before they change color/say “no artwork”. Record positions.

In my case I also cut some boundary strips once the lines were in position so that I can line up materials with less edge waste.

Are you restoring accordions? :smiley: I picked up a stunning antique accordion a few years ago to restore but the local expert retired before I could find time.

2 Likes

Possibly not… I didn’t consider that. One of the position shift changes that I saw was too much for rounding error though, it popped into negative territory. I put it down to me possibly dragging it a touch, and don’t really have time to do more testing. (Maybe some of you guys could check it. That would help the team to find it if it’s there.)

But it might be a bug in the code, and we might need to be careful with placement for now instead of relying on it for absolute positioning value near the boundaries until they can look it over.

Wow, that is a beautiful accordion.

1 Like

Would you believe I found it in a pile of rusty farm equipment in a barn outside Atlanta?

1 Like

Oh no, I’m sorry to hear you’ve hit a snag.

The maximum printable area can change based off of different settings as it can take space for the laser to decelerate when operating at high speed.

With that being said, I’m glad to hear selecting the center dot prevents the trouble from occurring! It also appears that @jules has shared some excellent steps documenting the trouble that we can escalate. Thank you so much for surfacing this trouble to us.

For our next steps, I’m going to have another team of ours to investigate further. I’m going to close this request for now, but should any additional questions or concerns arise, don’t hesitate to start a new post or email us at support@glowforge.com.

1 Like