Having issues with lag

Is anyone else having issues getting artwork to load? I have been having trouble getting my artwork to load, and if it does happen to load, the lag makes it darn near impossible to make any adjustments. I have rebooted the router and computer twice. I made sure there was not any updates for my browser or computer, and even went as far as to call my internet provider. It is just app.glowforge that is “laggy”

1 Like

It’s been happening to me as well since yesterday early afternoon… It just says “rendering” and then when it does load, you can’t edit…
I did put in a support email, still waiting to hear back. It’s an issue in the app. I rebooted my computer and my router and have even tried to access it from my iPad at work on a different system to see if maybe my home network was the problem. Generally this is cleared up fast- but it’s still happening today…


1 Like

Started about the same time for me as well. I put an email into support as well, but figured I’d check with all of you as well just to make sure I wasn’t making some “newbie” mistake! :rofl:

1 Like

According to the status page, all is ok. https://statuspage.glowforge.com/

The status may say “ok”… however it’s not. All of the saved projects in my library are not loading. I’ve been in contact with support, and I believe they are trying to figure it out. However, I haven’t heard back after I sent screen shots and a file for reference. It would be really nice to be able to talk to someone on the phone. I love my glowforge and have had it since May, operational with no problems… I don’t like the lack of accessibility to live support.
There’s something glitchy with the app interface. it just lags on “rendering your design” then times out.

*** Update***

So it allows me to upload a file as if it’s never been added to the gallery then I can get it to engrave/cut from there.

Alas it’s still not allowing any of my saved projects to open. I truly hope that they are able to figure this out.

Have you cleared your cache, closed the app and restarted? What browser are you using? Try a different browser and see if it is any better.

I appreciate your help :slight_smile:

I am using chrome, and even thought of that as an issue so I opened safari- and still the problem persisted. I closed everything out and even restarted computer and my router. I’ve accessed it from my iPad as well as my desktop (which is what I normally run it from).

Why would my cache affect the online storage for the files in the app? It may sound like a silly question. But if the files are stored in the “cloud” so that I can access them from any computer using my login… I’ll clear my cache to try that, but I still truly feel it’s a problem in the app. Or there wouldn’t be more than just me experiencing this- I came across this thread to see if there was anyone else experiencing issues.

I have been trying to open some of my smaller saved files and they seem to open, but there still is a lag. I noticed a few days ago that when in the cut screen (for lack of better term) that when I’d try to go back and adjust settings, it wouldn’t let me access all the individual parts.
Yet the larger layer files, that took me a while to set up, are the ones not opening now… and to be honest i use the machine most for that specific project.

another update- cleared my cache and it’s still doing it… hoping they can get this fixed sooner than later… :confused:

I’d suggest being extremely patient, and for the time being, using the files freshly uploaded from your desktop. It sounds like something server-side to me, and that might take them a while to track down.

1 Like

I’m so sorry you are having issues with the Glowforge App! I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.

1 Like