Having Trouble with engraving and cutting settings (after Mac OS update)

I am having the same issue. I can select the material, but cannot select my settings for cut or engrave. Also using Safari.

I tried turning off the add blocker and still nothing :frowning:

I don’t use a Mac so there is nothing more I can suggest.

It sounds like @dklgood does though, but it doesn’t sound like he is having any issues.

My thoughts are that either something has changed in the GFUI or Safari or the personal computer. Glowforge would have to address a change in the GFUI or Safari, but they cannot fix setting on your side. So we need to narrow down the problem.

If not all Safari users are having the problem, it suggests that the issue would be on a troublesome browser/machine. Make sure all your software is up to date, or at least the same version as someone that is working?

1 Like

Hi there,

Im also having the same issue. It started after I did the latest iOS update. Trying not to scream and pull my hair out but sheesh as apple is of zero help right now. Been chatting with them for the past 2 hours and still no resolve. Did anyone get any resolve to this issue?

I’m also having the exact same problems. Started when I did the latest MacOs update.

It sounds like the latest MacOS update is causing this issue. It sounds like others are getting around it by using a different browser (Chrome vs. Safari).

2 Likes

No :frowning: I had to send a support request. I found that if I zoom way out the options appear but you can’t click on them. I tried clearing cookies, incognito mode and restarting. Hopefully it’s something that can be fixed. I’m going to try from Chrome later today . I didn’t have it downloaded so didn’t try last night.

2 Likes

It bites when your OS does something that breaks website functionality - but at least there is the option to use Chrome on both major OSs!

Please let us know if Chrome fixes it!

3 Likes

There has been a rash of sorts…of complaints similar to this one. My iMac OS won’t update any further now because it’s too old, but I do know that there was a recent update for Safari and it’s sounding mighty suspicious.

3 Likes

If….and that’s a big if I remember when I get home I can try and verify some of this. I have an 09 iMac I’ve always used chrome on but can check with safari….last update was 5 years ago? And I have an m1 Mac mini that hasn’t been on in a few weeks so I can test, update, test.
But that won’t be for….6+ hours.

2 Likes

My iMac is 2014 and I can’t update past big sur, but I did recently update my Safari. I stopped using Safari for Glowforge stuff anyway a long time ago…and have just used Chrome exclusively for the GF. I think GF fixed any issues with Safari since then and it’s been working for people recently…until now, when apparently it’s causing problems again. I’ll be curious to hear what you discover.

2 Likes

Here is the response from Glowforge support:

Thank you for providing those details. Our team is seeing this too and we’re working to investigate the issue further. From what we’ve found so far, this appears to be limited to the latest version of Safari. If possible, while our team looks into this, using a different browser such as Chrome should lead to being able to use the app as expected.

4 Likes

Well, i suppose I dont need to feel bad if i don’t remember to test tonight…

2 Likes

Thanks for sharing what you found and the response you received.

This should be helpful to others having the same problem. At least we know :glowforge: is aware of the issue now, and they suggest trying a different browser for now.

2 Likes

Anything ever get resolved? I’m also using Safari. Always have with no issues. Until this ……

Oops, I see GF is aware and now looking into it.

1 Like

This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.