Head won't home, "BUMP" errors, $1500 to repair/replace

I’ve had a 6 month running on/off issue where the head will not home, while the app throws up “BUMP” warnings. I’ve gone through an extensive dialog with support (cleaning, checking, resetting WiFi, etc.). At one point I thought it was fixed, but now the problem is back. GF support now concludes that the machine needs to be repaired (or replaced with a refurb) at a cost of $1500. My machine is out of warranty. Does anyone have ideas to try that are not in GF’s standard troubleshooting pages? I’ll not be paying GF $1500 so I have nothing to lose. If this really is the end of the line for my GF, I will sell it for parts, cut my losses, and look for a laser that is more repair friendly.

1 Like

The bump -
My only idea is to feel the movement of the gantry and the head with the machine off to see if it feels smooth, and check the wheels for cracks and rails for debris.
For calibration -
Try centering the head under the camera before you turn it on.

You have probably tried that, but that’s all I could suggest.
Good Luck.


If support didn’t already have you do it, do what @PrintToLaser said and let us know what you see. Also inspect the belts carefully for any missing teeth, fraying, etc.

If there is a mechanical problem causing hitches and bump warnings, it almost has to be in the drive system and you can see all of that.

An electronic problem like a bad bump sensor or stepper is not going to be repairable, but it also seems extremely unlikely. I’ve been here from day one and have never seen such a report.

Good luck!


My advice is to really tighten your belts up, We had that issue a few times and solved it that way.

Update: My laser is back working! I started trying anything I could think of, whether is made sense or not. The last thing I did is completely unplug and reseat every connector on the board on the left side of the machine (see attached photo). I’m not sure if this will be a permanent solution, but it is working now. What I suspect is that since the exhaust flow goes right over this area, it’s a pretty dirty environment for the connectors. Tech support asked for a picture of these connectors when we were troubleshooting, and OK’d them, but I think that although they may have looked OK, they still needed to be replugged to wipe off a film of soot. Locating this board in the exhaust stream may be a weak point in the design.


Glad it’s working, but the ‘bump sensor’ is an accelerometer located on the underside of the head PCB, not far from the head camera and ARM microprocessor.


Great! Glad you managed that, well done.
It could be that when the machine was assembled the connection(s) weren’t seated completely. Over time and thermal cycling, the faulty connection could ‘creep’.
I had an old Marantz receiver that had a series of daughter boards that were inserted into the main board. Thermal cycling caused them to creep out of the slot until after a few years I had to open the case and re-seat them all.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.