HELP! Camera wont take a picture

Camera didnt take a picture!!! I cleaned my GF on Friday when the air assist needed to be cleaned (so I just decided to clean around while I was in there). Went to turn my laser on and camera failed to take a picture. I’ve had a black lid cable overnighted. That didnt work. Then I had the white lid cable overnighted, and now that didntt work either. What else can I do? I’ve cleaned the connectors…? Support hasn’t emailed me back and I have holiday orders. Ekk… I’m so stressed out! Anyone have any ideas? So frustrating.

I’m having a similar issue. I’ll turn the machine on and it’ll be stuck “scanning” or “centering” and sometimes will give the “camera could not take a picture” notification. So I turn it off, unplug, clean the camera, check all the connections, plug it back in and … nothing. Will not even power on. Been trying for multiple days. I recently deep-cleaned the machine and it was working great, no warnings or issues until this. Support sent me a really helpful /s article about checking the outlet when I requested help.

Deep Cleaning typically creates more problems than it solves.

not powering on might mean you shorted out the controller board during your deep clean.

it might have just taken a while for whatever cleaning agent you used to seep to the wrong place.

1 Like

I didn’t use any cleaning agents that would seep into anything - cleaning was done a couple weeks ago and everything was fully aired out before reassembling. Machine worked fine after cleaning. I’m just perplexed as to why it will power on the first time, but not the second (or third or fourth…) try after running into the camera issue. I’ve tried it daily for almost a week now, same thing each day. Was your issue resolved?

I fortunately don’t have any issues with BEAMER.

the obvious thing comes back to is there power in the receptacle?

is your power cord seated all the way in the back of your glowforge?

I had a wire pop loose on a receptable at my old house. never saw that before in my life.

when I took the plate off and removed the screws for the receptacle it came out with only 2 wires connected. freakiest thing I had seen in a while.

Oh, my bad, I thought I was responding to the original poster with the camera cable issues. To answer your question, this doesn’t seem to be an issue with our electricity. The machine will power on just fine, run into the camera issue, I’ll troubleshoot (turn off, clean camera, check connections) and THEN it won’t turn back on, for the rest of the day.

well your message stated it wouldn’t power on.

"Machine worked fine after cleaning. I’m just perplexed as to why it will power on the first time, but not the second (or third or fourth…) “”

Chris

Yes and no. Here’s what happens DAILY since last week:

  1. Plug machine in, turn on (lights turn on, machine acts fine)
  2. Open (any) file in UI, machine is forever “scanning” or “centering” and sometimes (not always) “camera will not take picture”
  3. Follow camera failure troubleshooting (turn machine off, check connections, make sure everything is clean)
  4. Plug machine back in, flip switch and nothing happens (no lights, clicking or fan noises)
  5. Unplug, wait, plug in, flip switch, no power …
    Repeat daily :frowning: