HELP! Just set up my unit, don't know how to start!

I just got my new glowforge set up and it’s ready to go. I got the beginning project they said to try, the Gift of Good Measure keychain design. There really isn’t any instruction that I can find on 1. WHERE to find the design 2. what software to use 3. how to put designs into the software, etc.
I’m at a complete loss & don’t know how to try this first object. Can anyone help me please? I’m very computer literate, but have NEVER used any kind of design software. Thanks.

It’s in your dashboard, no design software necessary. Have you successfully been to yet?


Yes. When I click on DASHBOARD, nothing shows up!

Odd—and frustrating.

What computer/operating system are you using and what is the Web browser?

If it’s a Windows PC use the “PrtSc” button to take a screen-shot and then use “Ctrl-V” to paste same into a “Reply” to this post. That will show us what you are seeing. Maybe someone can spot something? :sunglasses:


Windows 10, Brave browser.

There’s nothing to see. When I click on Dashboard, it doesn’t do anything at all.

You might want to try a different browser to see if that’s the problem. If you’re using Windows 10, you should have the Microsoft Edge browser already on your system. Or you could download Google Chrome or Mozilla Firefox and try one of those.


Welcome to the forum.
Have you successfully connected your Glowforge to your home wifi system?


Thank you. Yes I have.

I still recommend that you share a screen-shot here of exactly what you see on your Web browser after going to :sunglasses:

1 Like

I tried Microsoft Edge browser, same problem. When I go to the app & sign in, it gives me the 3 setup options again, even though I’ve gone thru the whole setup multiple times. (“I purchased glowforge and the box has arrived,” etc.) When I click on Dashboard, it doesn’t do anything or go anywhere. Does the same thing whether I go thru the setup again or not.

When you did setup did you ever get a screen with confetti?

1 Like

What you SHOULD see is something like this:

Sounds like some sort of registration issue. Hopefully someone at Glowforge can help you! :sunglasses:


Oh my gosh, no, I’ve never even seen that screen!

I don’t remember.

I guess I just need to contact support. I thought it was a “me” issue, that I just couldn’t find it or didn’t have the right instructions. Thanks you guys!

Problem solved! I had to give support my serial number. Somehow it wasn’t attached to my account. Got the page I need now. Thanks everyone! Gonna make some $$ for Christmas!! Woo hoo


Hey @joyce.volant It was a pleasure working with you over the phone and I am happy we could get this resolved for you. Thanks for reaching out!

1 Like