How to accurately scale a cut?

There’s got to be a better way to ensure the scale is correct and the actual line lengths are what you want them to be. For instance, these parts are drawn at exactly 4.93" and when I cut them out, they measure 4.62". Slightly unacceptable. The parts were imported directly from Inkscape raw. If all we have to accurately measure parts is a ‘thumbnail and squinty eyeball view’ - or maybe (hopefully) I’m missing something. Oh, I guess you can’t post a picture here either??

Make sure you have the current version of Inkscape installed. The earlier versions use a different DPI value for SVGs that can cause discrepancies in the translation of size. Current version uses 96 DPI, same as the GF. :slightly_smiling_face:


Well that cured it for sure, thank you.
I would still like to see a measurement tool in GF to accurately scale something up or down rather than a ‘click and drag’ method.

If you’ve got the current Inkscape version now - your cuts will be accurate as designed. (No more need to scale in the GFUI.) :slightly_smiling_face:

1 Like

Yes,Yes,Yes! Can’t tell you how much time I’ve wasted try to get exact dimensions.

This didn’t work for me today, from Have the rules changed?

Rules are the same. Sorry, I’ve never used so I don’t know how it is setting up the SVG files.

Here’s an example SVG file, which I exported from a sketch artboard dimensioned: 1440x864. This creates an SVG like this:

<svg width=“1440px” height=“864px” viewBox=“0 0 1440 864”


Sadly, GF doesn’t get the hint, and scales it all wrong.

I then tried adding a rect of the same size, but… sketch exported it exactly one pixel smaller, so GF didn’t use that either.

No idea. Your file seems to resize in the GFUI for me. I can resave your file through Illustrator (zero other changes) and it loads the correct size into the UI for me.

The resaved file: (1.1 KB)

Not any huge differences that I can see in the code either… (unless I’m just missing something obvious)

Your original file:

<?xml version="1.0" encoding="UTF-8"?>
<svg xmlns="" xmlns:xlink="" width="1440px" height="864px" viewBox="0 0 1440 864" version="1.1">
    <!-- Generator: Sketch 51 (57462) - -->
    <g id="Artboard" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <path d="M577,244.5 L379,244.5 C375.410149,244.5 372.5,247.410149 372.5,251 L372.5,486 C372.5,489.589851 375.410149,492.5 379,492.5 L411,492.5 C414.589851,492.5 417.5,489.589851 417.5,486 L417.5,387.5 L425.5,387.5 L425.5,485 C425.5,489.142136 428.857864,492.5 433,492.5 L475,492.5 C479.142136,492.5 482.5,489.142136 482.5,485 L482.5,387.5 L489.5,387.5 L489.5,485 C489.5,489.142136 492.857864,492.5 497,492.5 L577,492.5 C581.142136,492.5 584.5,489.142136 584.5,485 L584.5,252 C584.5,247.857864 581.142136,244.5 577,244.5 Z" id="Combined-Shape" stroke="#979797" fill="#D8D8D8"/>

And the AI resaved version (no other changes):

<?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 22.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<svg version="1.1" id="Layer_1" xmlns="" xmlns:xlink="" x="0px" y="0px"
	 width="1440px" height="864px" viewBox="0 0 1440 864" enable-background="new 0 0 1440 864" xml:space="preserve">
<g id="Artboard">
	<path id="Combined-Shape" fill="#D8D8D8" stroke="#979797" d="M577,244.5H379c-3.59,0-6.5,2.91-6.5,6.5v235

Some comparing my original (blue) to your version (orange):


My version comes out too small - about 5/6 size.

note that exporting to PDF works great.

Update: The output included this:

<g id="Artboard" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">

When I edited it to look like this

<g id="Artboard">

everything worked perfectly.