How to change material thicknerss

I am using materials I did not purchase from GF. I would select “Use Uncertified Materials” and it used to ask for the material thickness and as long as it was accepted, as long as I entered it in the currently selected unit of measure (UoM) or I suffixed the thickness with the UoM in lower case, everything was good.

Passing the UoM in upper case fails and results in 0, being silently passed backed to GF without any error being given to the user. That’s a bug any beginning programmer should be able to catch.

After owning the GF a few days I started seeing the Material Thickness data entry box being greyed out and would i would not be able to enter into it, it would have a prior entry in the current UoM or prior UoM, would be 0 or would be “Auto” AND would be unchangable.


This is a minor problem compared to the other one am experiencing, but I the only what I know to get around this one is to stop using the GF for a few hours and it will automagically start to work.

I have tried selecting proofgrade material, then i am stuck with it, i have tried going in and out of the app. I have tried restarting the laser (why?!).

I have 11 other copies of firefox open each with many tabs so i have been reticent to shutdown FireFox or Linux.


1 Like

Yes, it is currently broken.



If you use Set Focus on the material it locks out the Unknown Material thickness entry slot. Try just backing out to the Dashboard, then reopen the file and you should be able to enter the thickness.


Try it now. Mine started working again just a few minutes later.

1 Like

If you are referring to the “Focus Height” for the individual materials or items on the cutting table (under Manual, I can never get into Custom), I never adjust that, only speed and power. Focus Height always seemed to reflect what I had manually set under Material Thickness.

If you are referring to Set Focus somewhere else, I can’t think of where.

Thank you for your quick response.


Mine started working after I made my post but it is only a matter of time before it starts acting up.

I am currently only having problems with it cutting off the edge of the paper, where it said it wasn’t going to, but I am still collating data on that problem.


“Set Focus” is a command used to measure the thickness of the material and set the focus accordingly. It is under the three vertical dots in the command bar. I use it on every job. First I put in the material, then I “set focus” & then I position the art & cut. I rarely ever use the material thickness field.


I found it accidently when i use the ellipse menu to refresh the bed image, but i never used it so i dont know what it would have locked me out of adjusting my material thickness munaully, or why it would suddenly fix itself.

On a possible related note. I was working on a project, cutting objects from a wide sheet of ply by moving the objects into the cutting area and out, then moving the cutting marks into and out, and then sliding more ply into the slot on my Pro machine and sliding more objects to be cut into the cutting area.

I had to got my makes messed up with my objects had to straighten them up, added a vertical cutting mark to save a strip on wood and when i went to cut my wood I got and error message about only being able to cut items less than 0.5 inches or so. When I checked my objects, the Focus Height was all Zero for all objects, including the new one I had just added. When I checked the Material Thickness, it was still 4.36mm and could not be changed.

I had not gone into the ellipse menu and adjusted the Set Focus, nor had I set the Focus Height on any of my objects.

What is going on?


Is it possible there are holes in your material that are messing with the auto focus?

I am not using to autofocus and can’t figure out how to turn it off, and i don’t know if and when i want it on. right now I am focusing on the wood are to the left.

What are the gotchas of leaving it on, besides areas when holes, and how do you turn it off ?

When I went in and turned in on, I saw a pair of targetting markers on screen. Those were no there before when on received the 0.5" error, there is something screwy with the GFUI.


I did a cut, and now I seem to be off of Auto Focus Height.


The best way is to use set focus instead of relying on autofocus. That way you can choose where on the material you want it to focus. Otherwise you risk it autofocusing in a hole, which pretty much scews up everything.

1 Like

I’ve never used “uncertified materials” selection–though I rarely use materials purchased from GF–but I select the type of material from the list closest to mine–it’s just a fast way to define the settings. I used to then manually enter thickness, but now use set focus more often to adjust when my material thickness as necessary…

1 Like

I’m sorry you ran into trouble while using the app to set up a print. If you’re still unable to manually enter the material height, will you please try opening and closing the lid of your unit, and then check again to see if you’re able to enter the height?

Regarding running into an issue with alignment and measuring the material height using set focus, I extracted the most recent logs from your unit to take a closer look. It looks as though your Crumb Tray might be shifted towards the back of your unit. If the tray is out of position, it might impact the height measurement and alignment of your prints. Will you please do the following?

  • Turn off your Glowforge
  • Remove the tray
  • Check for any debris which might be preventing the feet of the tray from settling into the depressions in the bottom of your unit
  • Re-insert the tray and feel for the feet to settle into the depressions in the bottom

After doing the above, please turn your unit back on, use Set Focus and try another print. Let us know if your alignment improves!

The problem with not being able to enter material height fixed itself and now the problem is back.

I started using Set Focus because it was a quick way to to the focus for a piece of paper i wanted work a design out on before committing it to acrylic. I clicked Set Focus, i aimed the focus pointer in the middle of my object to cut in the middle of the paper, i pressed print, and i get an error message about size being less than 0.5". The first time I tried it, I may have forgotten to focus the pointer before pressing print, although I think i focused it at the paper. The next I focused it in the middle of the model. Both times, when i went and looked in material Thickness it had something unchangeable. I just tried it again, and it has an unchangeable value of 0. In any case, it is May 21 at 12:50 CST should you wish to examine the logs.

As for the crumb tray, I didn’t realize there were slots to help with alignment and was pushing the tray all the way to the back so I could try and get material squared up.

At one point I had also tried running the laser without the crumb tray since I had seen GF tell me my material could be between 1.5 and 2" with the tray removed.

Currently, I am unable to use the GF because of material thickness problem. I tried to cut a 1 cm circle (created with the gf ui) on bond paper using set focus, i get print stopped, you material must be less than 0.5" tall …


@jules I found Set Focus and I have been using it, it comes in handy for some of the wood I have bought from Home Depot. I just use Set Focus instead of getting out the calipers or finding my notes.

I was having the problems again and I tried going to the Dashboard (where all my designs are located) and when I came back to material thickness, it was still set to 0 and unchangeable. I then went to Community and then went back to the Dashboard, created a New Design and now Material Thickness is set to Auto.

I wonder if it has something to do with running Linux instead of Windows.


Some people seem to have trouble having the camera focus on something really thin like paper if they have not run Camera Calibration yet. Did you run that yet? (Might help.)

I closed out of all GF tabs in my browser for a few hours. When i came back, restarted the GF, I started a new design, uploaded a file, set the material thickness, set the power, burned a copy, re-uploaded it, reset power, burned a copy, moved it to a new spot on the material, and when I tried to print again, I got the material thickness error.

Going into the left side where i set the objects power and speed, i can see the Focus Height is set to ‘auto’, and i can’t change the material thickness. At no time did I go into Set Focus or that menu.


No, I hadn’t heard of it. I will read up on it, it looks like it has information on Set Focus too. Thanks.


Printed some more, then got the material thickness error. I printed one object after specifying a material thickness of 0.21mm. i deleted that object and uploaded two variations to try, moved them into position and pressed print, GF aborted with the material thickness error. Both objects to print have a Focus Height of “auto”, but the material thickness is still set to 0.21mm and is unchangeable. I have changed to thicker paper, from 0.08mm to 0.21mm

@ivan1 help maybe ? I need a reliable way to reset this rather than waiting a few hours. I just tried entering 0.21mm into the Focus Height fields of both objects to cut and I still get the thickness error. I was hoping I could get back to work that way.