How to not engrave the inside of letters (like A or B) I did read the tutorials!


#1

Morning GF Community,

First off let me say, I did read the tutorials by Jules on compound paths and laser design basics and read some posts in the forum.

BUT, I still can’t get this for some reason. Not sure if it’s me or the file I’m working on or something I have done to the file that is not making it work for me.

In this file I have the letter A and B and all I want to do is make the inside of the A and B not engrave. I cant get the main letter shape to be white and the inside s to be no fill so the glowforge doesn’t engrave it.

As you can see I got the letter A in the middle to be no fill but now I cannot get the rest of it to be filled in white. The letter B I haven’t even touched yet as after 4+ hours of trying things I’m ready to cry. lol.

If anyone could spare a few minutes to look at the file and tell me what I’m doing wrong I would appreciate it.

2-Engrave actual image copy.ai (94.9 KB)


#2

Hang on, it had a couple of issues…I’m writing it up. (You were almost there, but that B requires special treatment due to two passes at the subtraction.)


#3

Okay, first of all - the easiest way to do it is to simply rasterize the engrave once we have them looking the way that we want them to look. (The Glowforge does just as good a job with raster engraves as with vectors in this instance, so it’s quicker sometimes to do it that way if you get stuck.)

For this image, you would just fill the shapes and lettering with black, set the strokes for everything to null, select everything but the cutline outside, and then click on Object > Rasterize. You can use a high dpi (600) and you’re not going to be able to tell the difference from a vector engrave. Just make sure you Embed the image when you save the SVG file. (In the popup.)

Note: If you want to be able to change things later though, make a copy before you rasterize it and hide it off to the side so you will have one to change later. :slightly_smiling_face:



Okay if you want to fix it via vectors, there were a couple of issues with that A and the B.

First I turned on the background grid so I could see where you had white fill and where the cutouts were performed correctly. You can see that the A consists only of strokes, no fill, and the grid shows through both shapes. The B has white fill in both the center sections and in the body, so those have not been subtracted out yet.

To fix these, you need to Ungroup several times and Release any Compound Paths so you can work from the bottom up.

For the A, I filled both shapes with yellow (so I could see them, the white is too hard to see for me), then I selected both and subtracted using the Minus-Front tool in the Pathfinder palette.

The B had a duplicate line for the base underneath it that was messing up attempts to do the subtraction at first, but basically, I just released the compound paths, made sure I was down to two center shapes on top of one base shape, then performed the Minus Front calculation twice. The first time that you perform it with one of the inside shapes on the base, the resulting compound path is going to move to the front, and you have to shift it to the back to use Minus-Front again with it. That’s just the nature of Illustrator, it can be a pain in the tush.

Once those were corrected, I selected everything inside the rectangle, gave it no stroke and black fill, and that is now set up to engrave correctly. The interface will correctly interpret that as an engrave because there is no stroke color associated with it.

I also took out a clipping path that was in there - they tend to cause error messages in the interface.

3-Engrave actual image copy.zip (6.0 KB)

You can see why it’s sometimes easier to just rasterize it. :smile:


#4

Now I know how people feel when I talk tech to them. I feel the same way reading this and trying to put it all to practice!

I’m reading and trying to follow along with what you did. I was able to ungroup everything and release all paths and I was able to get the letter A done now but the letter B is still making me work.

I think its because I dont see the duplicate line underneath yet. Im trying to figure out how to see it. I went layer by layer and tried to highlight it but I dont see it. Im assuming once I get rid of that when I select the letter B and do the pathfinder minus front it will work as it should. Right now when I do the minus front it looks like this.

1

Are those 2 lines the ones your talking about? I did try to delete them and try getting the rest of the B back but I cant, it’s gone! Either hiding from me somewhere or I really deleted that too. lol

The reason I wanted to vector engrave is that I have read it produces a better look, more sharp and clean but now that I read what you said about it I shall give it a try.

I refuse to quit on this one though as this is making me better at AI and I know I will eventually get it.

You have no idea how much I thank you for all you do to help people in this community! Even if they are like me who rarely comment and post. (I’m a noob and cant see how I can possibly help or add any value)


#5

Everyone’s good at something - just help out folks with what you’re good at. Doesn’t have to be lasers yet, but one day very soon it can be. :wink:

You’ve got it…those are the lines, but because they were underneath the B exactly, they were interfering with the Minus-Front operation and you can’t really find them until you make the top B invisible.

It’s not a big deal, and it probably won’t happen the next time you try to do it, so just play with using the tools in your spare time and you’ll pick it up in no time. ( It took me a full year to learn Illustrator enough to be comfortable with it, it’s not the easiest thing to use cause there are so many options.) :slightly_smiling_face:


#6

Jules,

I did it!!! I finally got it and its because of you! :grinning:

Thank you so much. I know this is simple for others but this is huge for me and my ongoing learning.

And…here is the screenshot for proof! lol

2


#7

That sounds like an interesting test to try. I did some tests with input resolution (and 600 DPI is definitely the way to go with raster - if you can). But I should compare vector to raster.

Also, if you want really clean letters - put a score on top of the engrave and run it after the engrave(a light score). That will make the edges very clean.


#8

Thanks for this score tip. I have read that in other posts as well. I have yet to engrave a raster, only engraved vectors strictly as I thought it wasn’t going to turn out as nice. I will definitely be trying it out and the score around it as well.


#9

Oh fantastic! There will be no stopping you now! :wink:


#10

Argh! Ok, one last question on this one. I just loaded it in the GUI and hit print but the laser doesn’t fire, the heads moving though. So I loaded the file you zipped up and tested that one and it works!

I have never had an issue with my files before and I save them all the same way using the same settings. Have you ever had that happen or would you know why this is happening? Here is a screenshot of my save settings.

And the file just in case you think you need to see it.

test-2-Engrave actual image.zip (67.6 KB)


#11

I think that clipping path might be messing things up in there - try deleting that in the Layers palette, then save it again. Those settings are fine.


#12

Ok, deleted that and re-saved. Same problem.

I did notice after loading it in the GUI and hitting print, and after it scans and loads the design but before I hit the print button it shows the preview of the engrave. Mine just barely shows very tiny dots in a few places here and there. Yours loads and shows the entire solid engrave like it normally does.

Stumped on this one, I looked at you file and compared it to mine now that I deleted the clip and they look the same to me. My head is spinning after all this time today with this, lol, I’m taking a break for today and will revisit this tomorrow.


#13

Might try ungrouping. It was the only other thing I did to your file. It shouldn’t have impacted it, but it’s all I can think of.


#14

You answered back so fast I had to try that. :joy: Tears of joy! Its working.

I have no idea why that would cause this but right now I don’t think my brain can comprehend much more. I will be able to sleep tonight now that this is working because of you.

Thank you again!!!