Hung up on "Rendering your design"

I recently created a small box with engraved details and printed/cut it with no issues. I’m now trying to cut 6 of those boxes from a single piece of material and running into issues.

What I’ve done is to import the box SVG and then rotate and move the individual box pieces within GF to optimize material usage and reduce waste. I repeated this step multiple times - importing the SVG and rotating moving parts.
Each time I added another copy of the box, it would take longer and longer to load it. By the fourth box I was getting a message that the page wasn’t responding, however the box loaded within a few minutes.

I was able to load all six boxes and minimize the waste. I exited the application without any issues. However, I’m now trying to reopen the file from the design library to print it and I’m stuck at the “Rendering your design” screen.

I’ve let it sit for over 15 minutes to no avail. (I’m currently using Chrome. )

Any help would be appreciated.

Thank you

I would try setting up the file the same way but use inkscape or another program like that and combine all the engraves into one png file. The browser has a hard time with projects that are a large file and will refuse to work on one that is over 30 Mb. Im thinking that as you have been adding more and more copies of that box it had gone beyond that threshold. Like your project might be around 10Mb and then you can copy it multiple times and end up somewhere around 60Mb which is causing the issue.

1 Like

Mine is froze too. Same screen “Rendering your design”.

Welcome to the forum.
If you want assistance from Glowforge support, you need to start your own thread rather than jump on the end of another post. Try loading a different file - like the Gift of Good Measure. It it loads, then you can assume the problem you are having may be with the file. People here on the forum may be able to help you if you are a bit more specific about the type and size of the file.

I’m so sorry to hear that you’ve hit this snag. Does this same trouble occur if you attempt to open an alternate design, or is it one design in particular?

We need a bit more information to investigate. Please do the following:

  1. Go to https://www.whatismybrowser.com/
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

This will help us understand the circumstances around your error so we can work on it for you.

Let us know how it goes!

Thank you for all the replies. I tried one more time and let it sit for 25 minutes… and it FINALLY loaded the design. I think it was just a matter of it being a very large file.

1 Like

That worked for us after updating Chrome. Thank you from Creatively Southern

Thank you for letting me know. I’m glad to hear that you were able to resolve the trouble. I’ll close this ticket for now, but please don’t hesitate to reach out to us directly at support@glowforge.com in the future if you run into any more trouble. We’re here to help!