I can't see my print bed from my computer

I just got my new Glowforge Pro on Tuesday it’s never worked. I can’t see my print bed from my computer. I never could it won’t move past centering or scanning. It fires then draws a diagonal line but never cuts out anything. I just don’t know what to do please help. I tried all the basic trouble shooting. I waited so long to get this machine for years and spent a pretty penny. I should at least be able to get a phone call. I had no trouble reaching a sales rep to buy it. Yet to fix it without knowing the problem why would you recommend I buy something for a less than 72 hour old machine that cost over $7,000. this needs to work or I need my money back. I really want this to work. I’m a hobby crafter who loves her Cricut. HELP ME!!!

Welcome to the forum. I am just an owner like you are, so not official support. I am wondering how the Glowforge fires and draws a diagonal line if it won’t move past centering or scanning.

My suggestion is to double check that you have clicked in the white cable properly to the printhead. Insure that the printhead is properly seated on the carriage. Make sure the honeycomb tray is properly installed with nothing underneath the feet in the dimples. Take everything off of the honeycomb tray before turning the machine on. Share a screenshot of what you are seeing.


I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.