I dont know what to do

i went to clean my lens, i placed the tool in heard the click ,when i pulled it out, the lens stayed in place and the ring that was on the tool is connected to the lens. the silver ring came off the tool. has anyone else had this happen ?

1 Like

Stay calm. Remove the lid of your printhead (it has magnets). Then gently remove the mirror which has a blue handle. Carefully use a qtip to push your lens down and out of the printhead. Make sure you catch the lens or have it land on a very soft surface.

Your can remove the magnet from the lens and then reinsert it when you have cleaned it.


Ty im so afraid of hurting my baby. I was in tears

1 Like

@bobbijodecker I am so sorry the ring came off on your lens tool.

I see that you sent us a chat yesterday to assist in replacing the lens tool but I also wanted to confirm if you were able to remove the existing metal ring stuck in the Printer Head. I’ve included a link below with some instructions.


Please let me know how it goes.

1 Like

Happened to me once :slight_smile: I did was @dklgood suggested and was back up an running.

QA is not always great with a low cost part like the lens remover. Sometimes that metal ring will separate.

yep it worked ty

1 Like

@bobbijodecker I’m so glad it worked.

I sent you an email last Wednesday, 10/19. Can you confirm if you receive the email? Once we have your reply we’ll be able to assist in sending you a replacement Lens tool.

yes i got itand do need the replacement tool

@bobbijodecker Thank you for confirming you received the email. I sent you a new email. Please go ahead and reply to the new email with your information. 'm going to go ahead and close this forum post and we’ll continue following up with you there.