I get an Error until I don't

Anyone else having this problem? Any file I load to print gives me an error. I have tried to reload the browser, cycle the machine, roboot computer. The only thing that works is repeatedly loading the file 4 or 5 times until it finally works. This started about a week ago and seems t be getting worse.

He is an example file I am trying to upload. It takeserror GF file.zip (697.8 KB) about 5 tries until it loads.


I saved your file as an SVG and had no trouble getting it to load. Did you try it as an SVG or are you loading it to the GFUI directly as a cut and paste? You might try SVG and see if it makes a difference. Otherwise, I would suspect Wifi issues but the only time I’ve ever gotten that message was when there were problems in my file.


I have had this error a couple times before, and as @cynd11 noted, only with certain file types, but never have had this with svg, or jpegs (which is >95% of file types I work with).


@jonnyvermont I’m so sorry you hit a snag.

After extracting the logs of your Glowforge, it looks like you’ve been able to print since contacting us. That’s great! Were you able to successfully print the file you were running into trouble with?

If you’re still running into trouble please don’t hesitate to let us know.

Ok, this is perplexing. I understand that the errors are often caused by wifi issues, but I am not sure that is what is going on here. I can connect to the GF easily. I get a bed image right away. It is not until I upload any file to the GF that I get the error. Specifically, this is what happens:

  1. I close the lid.
    —> I get centering, scanning, and lid image quickly.
  2. I choose am SVG to add to the GF
    —> 2a I get the message " Uploading… Your design is being sent for printing. Learn more about uploading.
    ----> 2b I get the message "Processing…
    Your design is being prepared, arranged into groups, and separated into steps. When this is finished, you’ll be able to position your design on your material. Learn more about uploading and processing.
    ----> 2c I get an error: Error
    An error occurred on your Glowforge. Please refresh your browser before printing. It may also help to turn your Glowforge off and then on again.

If I simply repeat step two 4 or 5 times, it will eventually load.

I just tried this with a simple circle in an SVG. I have been a GF user for over two years, so I have a great deal of experience generating files from Illustrator and converting them to SVGs for the GF. This is a new problem. If I can get the bed image quickly, wouldn’t this indicate I have a decent wifi signal?

Can you see in your logs where I repeatedly get an error 4 or 5 times?



OK, I have found the problem, and it is not GF, but I hope you can still help me.

I noticed that when I save an SVG, it also creates a temporary JPEG file with a file name that changes constantly and goes from 0KB to 137KB. This will replace itself with similar alphanumeric file names for about 1 minute and 15 seconds for a simple file. when it finally goes away, I am left with only the SVG which will load into GF.

Any ideas what is happening?

By the way, the way I save files is the following:

In illustrator, I get the canvas the way I want it, then a I “Save a Copy”. I switch the file type to SVG. I answer the dialog box, then it saves,




I’m sorry about the ongoing trouble importing SVG files into the app. Thank you for providing detailed information about the error messages you were receiving as well as your export settings. Will you please try the following?

  • Open one of the files you’ve had trouble with
  • Click file>save as
  • Select SVG
  • In the SVG options, please use these settings:



After saving the file with the above settings, please try uploading it in the Glowforge App and let me know if your design opens as expected. Thank you!

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.