I get "linked images" error message every time despite embedding image in Illustrator

Using files I have successfully used before, every time I try to upload an svg with images embedded, I get this message:

“The linked images have been removed. To print images, you can use design software to embed the images when you save the file.”

I’ve repeatedly “embedded” the image in illustrator, re-saved, but still I get the same message. This didn’t happen before, but I can’t get anything done. I’ve tried everything I can think of and not even the two glowforge support staff I’ve chatted with seem to be able to figure it out so far.keep%20it%20runnin%2012%22%20invert%20tombstone

Can you post an example file?

I just added it to my post. The image isn’t showing up…which seems like it would make it an illustrator problem, but I’ve tried it on Adobe Illustrator 2017-2019 and still no dice.

I think the forum strips them out. Try a zip file.

I’ll take a look at the SVG code in a little bit when I get back to a computer. Maybe a phantom reference to what was a linked image, or who knows. I imagine if the software sees a call for an external file (even if a copy is embedded), it’s going to throw a flag.

keep it runnin 12" invert tombstone.svg.zip (1.3 KB)

1 Like

It’s definitely not a Glowforge problem, that file is referencing an external image with this code:

<image style="overflow:visible;enable-background:new ;" width="3600" height="3600" xlink:href="keep it runnin large 12&quot; invert.jpg" transform="matrix(0.24 0 0 0.24 194.2629 -147.0247)">

Can you share a screenshot of your Illustrator export settings?


Here’s what the correct options should look like. I was able to reproduce your problem if I set the “Image Location” to “Link” instead of “Embed”.


How do I get to the svg options screen? This is all I get when I try export or save as or save a copy. Sorry, I know this is illustrator, not glowforge, but I do appreciate it.

…and I found it…just had to continue and click export. Seems to be working. Thank you!!!


Embedding it into the Illustrator interface is one step (that isn’t necessarily required). However, when exported as a SVG you’ll again have to tell it to embed (as you found out).


I’m glad to hear that resolved the issue for you (thanks for the answer, @chris1!)

I’m going to close this thread, but if you run into any other trouble please start a new topic. Happy printing!