Image size reduced when uploaded to GF

I’m trying to resolve issue when I upload file to GF. The size of the image is different than the size I created in Inkscape. Example Inkscape 3.003 X 5.491 inch. When I upload it is 2.964 X 5.451. It is consistent if I save as SVG plain or PDF as well if I change image in Inkscape to px. It does the same thing if I use a file I have purchased which is likely created using a different design program.

If you take a file you purchased and load it on the GF it comes out smaller than it’s supposed to? Or you take a file you purchased and save it with Inkscape and then load it and it comes out smaller than it’s supposed to?

How are you measuring the files you purchased to know how big they’re supposed to be?

Do you have another graphics program you can use in lieu of Inkscape?

1 Like

Check (under preferences, input/output, imported images) your default export resolution in inkscape. It needs to be set at 96.


I figure at this point I need to focus on images I create in Inkscape. I know the measurement in inches is 3.003 X 5.491 and saved as plain svg.
When I upload into GF it will measure 2.964 X 5.451… That messes up my slots.

Hmm. Well… 2.964/3.003= 98.7% reduction. But 5.451/5.491=99.2%. So the scaling isn’t the same for X and Y. I’m not sure how that can happen no matter what graphics program you’re using and how much it differs from the printer’s expectations for scaling.

I’d argue that 99.2% is effectively 100%. The delta is small so it could easily just be measurement error. But it sounds like about the right amount of error if you haven’t accounted for Kerf. The laser follows the line itself, so half the beam width cuts to one side of the line and half the beam width cuts to the other side. The object is half a beam width smaller all the way around. So when you measure the full width you’re measuring two cut edges. 0.8% of your object’s target width is about 1mm which is, I think, pretty close to the beam width.

The other axis, however, is pretty far off. You should ask Glowforge to check your machine to make sure the steppers are calibrated correctly. The only way I can think of this happening is if the steppers themselves aren’t using the correct number of steps/inch.

1 Like

Have you changed your Inkscape preferences to disregard stroke width in calculating sizes? By default it accounts for the thickness of lines. But the GF disregards stroke thickness and treats lines as if they have a zero thickness centered in the space that the Inkscape stroke occupies.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.