In Inkscape, Half Doesn't Mean Half

inkscape

#1

I am making this large, wall hanging wine cabinet/rack (not with the glowforge). Well, my forstner bit jumped out of the hole that I was drilling by hand and really marred/chewed up the surface of the last piece of plywood I had on hand to build this thing.

After talking to a friend, he suggested just cutting out a ring on the Glowforge and glueing it around that particular hole as an accent. So, that’s what I was modeling last night.

I went over to Inkscape and started with the circle that I needed to match the diameter of the drilled hole. It was 2.0025" on my calipers.

I input the dimensions in Inkscape. Then, I duplicated and told that new circle to be 2.252" (which should be 1/4" larger than the first one I drew, right?). I cut that out, and the first circle matches what I measured with the calipers, but the outer ring does not. There was not a 1/4" gap between the inner and outer ring. Why?

So, I tried again…this time, making the outer circle 2.502". That should make it 1/2" larger than the inside circle. Again, I get it out of the Glowforge and well, you can see for yourself what it measured as from this photo:

Why is that not measuring 1/2"? Is all of that difference because of laser kerf?


#2

Assuming it’s not a dpi conversion issue (I doubt it, it’s too close to be that)

You’re talking 0.0135 error.
Highly likely kerf, as that’s 0.00675 error per side :slight_smile:

At that rate, measure it in a steamy bathroom, I bet it’s 0.5 from absorbing huimidity. :slight_smile:


#3

Ha ha…funny about the steamy shower.


#4

I’m just glad I don’t have to account for 1/4" error like I do w/ my table saw!

That’s just too big to take in the shower with me :slight_smile:


#5

You likely have two problems (possibly three but let’s ignore kerf effects — that’s been covered enough in other discussions):

  • Circles are measured by diameter, so you’d expect your first example to have a gap of about 1/8, not 1/4.
    If you wanted a 1/4” gap, you should set the width and height to be (original) +0.5”.

  • unless you changed the default, the size measurement of your circles included the stroke. I suspect if you’re asking this, it’s a safe bet that you didn’t change that setting. This will mess with your accuracy. When dimensions are critical either set the bounding boxes to ignore stroke (in your prefs) or temporarily set the circles to have fill and no stroke, get them to your exact sizes, then set the stroke/fill back to what you wanted.


Inkscape and Stroke Width and Kerf, Oh, My!
#6

Oh, I see, so when I set height and width of the circle in Inkscape, that was for radius? So it ended up being half as much as I needed?

That’s really helpful about the stroke. You’re totally right…I didn’t mess with the stroke setting. I will pay more close attention to that next time.

Thanks for the tips!


#7

No it is diameter so it was half of what you needed. If you wanted a gap of 1/4”, that’s a radius increase of 0.25. That corresponds this diameter increase of 0.50.

It seems simple but it’s an easy thing to get wrong, I’ve learned that lesson a few times, and probably will again. Moving too quickly or something :slight_smile:


#8

Ok…I think we were saying the same thing, but I wasn’t wording it right. ha ha
Thanks for the clarification. It really can get confusing.


#9

Another very minor source of error to watch out for… Make sure Inkscape Preferences-Tools is set for Geometric Bounding Box and not Visual Bounding Box. Otherwise you get a hard to find error associated with the set width of your stroke in Inkscape.


#10

Will do…thank you!


#11

Also when you select something in Inkscape it will say up at the top the bounding box lower lefthand corner, and the width and height of the object as it will be sent out. You can use the arrow keys or just go in and type a number and it will be that, but if it was centered before it will not be as the corner of the bounding box will not change.