Inkscape 0.92 with Ubuntu 14.04 - anyone else using this combination?


#1

I’m getting the hang of inkscape, having moved over from 20+ years with CorelDraw, but found some things baffling !
The most irritating is getting it to display the rulers in inches when the document opens each time.
Is this possible ?
I’ve tried using the ‘Document Properties’ tab, as per many postings on the web, but this seems to have no effect when I change the ruler from pixels to inches.
Some time ago I managed to create a GF template which opens the ‘New’ file, but I havent managed to get it to default to the inch rulers.
Anyone any ideas ?


#2

I think that’s under “Edit | Preferences” for the program itself. I’m away from my mac at the moment or I’d verify. Should be the same in Ubuntu.


#3

I’ve had a look, but can’t find a ruler option, only in the Document properties window.
If I change the setting to inches, or anything else for that matter, it has no effect on the rulers. They stay permanently in pixels !
I’ve just checked that there is a later build - 0.92.3, and mine is 0.92.2, so I’ll try downloading the latest version. Might help !
John


#4

Apologies… The only sure-fire method appears to set up a blank document, then save it to the template directory, which varies by OS, then use it for all new documents. Yuck.


#5

There are two places in the document’s properties to change. One changes the units and the other changes the rulers. Set both to inches.

Yeah, and then save the template. If you open a document that you did not create it will default to the document properties used when that document was created.


#6

While I can change the units in the Document Properties menu to inches, for both the ‘Display units’ and the ‘Custom size/ Units’ buttons, unlike the demo videos I’ve seen on You Tube, the actual rulers on the inkscape window don’t change !
So if I save the template, it still reloads with pixels as the ruler setting.


#7

Don’t know what to suggest. I’m using Windows 10 and the ruler changes immediately after the selection. Looked it up in the Ubuntu forum and the solution is the same. Sorry, can’t test it myself so not much help.


#8

Hokey smokes! This was driving me nuts, so I loaded Ubuntu in a new VM, then installed Inkscape. I’m seeing the same behavior – changing the two document plus the application grid settings had zero effect on the rulers. :poop:


#9

Using Inkscape on Windows (7 & 10) and the change rulers to inches only mostly works for me. On some documents I can change the display units to inches and it utterly and completely ignores me. Never on something I have created, but sometimes on svgs from other sources.

Not related to your issue. Posted anyway.


#10

Thanks for the heads up. At least it means that it’s not my own created problem !
There is a 0.92.3 version so I may try that over the next couple of days. Bit busy at the moment trying to get work finished before my last (hopefully) trip back to UK.


#11

Don’t shoot the messenger, but my test was with 0.92.3 on 14.04.


#12

Oh rats…
EDIT
Just discovered that my printer can’t cope with Inkscape, but has no problem with any other software that I’ve tried so far !
Finger now pointing straight at Inkscape software as the probable source of the problem.
I’ve also got inkscape 0.91 on another laptop, and that produces a similar printing problem, ie it prints other software but not inkscape.