Inkscape pasting paths ... strangely

Has anyone seen an issue with inkscape (0.92.3) where copying and pasting paths goes really wrong?

I have perfect paths that I made, when I try to copy and paste it, it goes haywire, like the nodes and curves are all just wrong, kind of “wobbly”.

It’s crazy. I am trying to figure out if I did something in prefs that would cause this?

Wow, it’s not even cut and paste, just moving the path causes it go ape. What the heck did I do?


Reinstalled inkscape. No dice.

Rebooting now.

I am stumped. Corrupted file maybe? It’s not the only file that is doing it though.

My Inkscape is working as expected (0.92.3). Sorry.

Does it happen if you first “convert to path”? Sure seems like a bug.

It’s already a path, but I tried it anyway. No change. This is so weird.

Not all paths are the most basic type, and convert takes care of that. Still a bug regardless, but something to poke at.

Hmm, does a chopped out subset do the same?

You mean break the path and try a segment?

Moving a single node does it.

Cutting the path does it.

Dragging the source file into another SVG does it.

Changing colors didn’t cause issues. Hmm.

1 Like

What does it look like in Outline Mode (or the Inkscape equivalent)?

I meant carve out a subset with ‘intersect’. But you said cut also does it, so… Time to re-create the whole shape from scratch?

That looks like it could be a display/rendering/video memory hiccup to me if it’s doing it while just moving things around.

Good idea to double check in outline mode. If it looks wobbly there, then something is definitely screwy.

Good thought.

I moved the path, saved as a new filename, closed everything, and reopened the file.

Reopened the file, it was a dorked up as it was when I saved it. I looked at the nodes themselves, and the handles are all wonky. It seems to be actually modifying the path.

The viewing in outline mode was mostly to determine if it was possibly a video card issue, or a weird stroke appearance or something got applied.

I didn’t see where you mentioned that it was happening with other files. If you haven’t, I’d check that.

Copy/paste can also copy / paste over bad code. I would also look at recreating the file from scratch. Or, at minimum, run it through an SVG cleanse.

If you’re having trouble with other files, I would delete the preferences.xml file. I know you reinstalled - but a lot of times the program doesn’t completely uninstall/reinstall. It will keep things like preference files.

1 Like

I looked into SVG cleaners early on and didn’t find any one that people could agree on as “good”. You got one?

I’ve used this one before and it didn’t cause issues:


Deleting the preferences solved it! Now, lets see if we can find out what in prefs was the issue. These are xml, I assume, so let’s get medieval on it with diff and a blowtorch. (10.3 KB)

The POS file is the broken one. I’ll post back if I find anything suspect. I wondered if it was due to setting up randomize criteria in the tiled clone dialog, but I backed those out and saw no improvement.


Huh. I can’t find anything obvious in there. Moving on.

Thanks everyone, some good suggestions in this thread. Gold star for @jbmanning5


That was weird… post your preferences file and I’ll compare to mine?

He already did, didn’t he?

1 Like