Internet affecting the startup process of my GF

Hello fellow forgers,

Let me tell you about my night. I have been up since about 10pm attempting to solve this issue. My glow forge OUT OF THE BLUE decided that it no longer wanted to center. I would turn it on, fan would do its thing, click noises would happen. When it came time for the gantry to move…nothing… I though hmm maybe something is wrong. So I run through the normal trouble shooting, restart computer, restart modem, restart glow forge and still no movement. I then reconnected the GF to the same network again…and still nothing. In a heated rage I emailed customer service FURIOUS as I had no answer as to what was causing the issue.

Then I had an idea…" Maybe try using the UI on my phones browser instead of my MacBook." LOW AND BEHOLD IT WORKED. started up normally, gantry moved under camera to center, everything worked correctly. I could then load up the UI on my computer and work from there. However after a project finished It would be stuck on scanning. So I would have to re-do this entire process with the phone then switching back to the computer just to do another project. IS THIS A CONNECTION ISSUE!!! Now this process no longer works. I just spent $100+ on amazon buying a 400ft (over kill) ethernet cable and a router to connect to my modem across the house to provide a wireless connection that will literally be 6" away from my glow forge. will this solve the problem? I am running a business and I need this glow forge to work as it was intended.

1 Like

There are typically two things that cause this problem: not getting a good connection, or a failure in the cable that goes to the lid camera. Since your Glowforge has connected at least sometimes, it will have sent logs to the mother ship and GF support should be able to give you a better answer about whether it’s a connection issue or something else, when they get to this ticket.

In the meantime, I can only offer two bits of info/advice. One is that the startup/homing process does not use your computer in any way (it’s just the Glowforge talking to the Cloud), so the thing about switching to your phone for the UI is probably just a coincidence.

But I think you’re in the right track with the wireless. Those radio signals can be unpredictable – I had a WiFi printer that would connect just fine for months at a time and then not at all. I’m old enough to remember when TVs had antennas, and just standing in a different place in the room could affect the signal. So trying a different location for your WiFi router is a good first step. Sometimes just moving it is enough. You can also try setting up a hotspot on your phone and connecting through that, not to permanently solve the problem, but as a way of testing whether a different WiFi connection changes things.

Oh, and one last mini-tip: sometimes having the router too close can cause problems too. These things work best at a certain power level, it’s kind of like turning the speakers up until it’s just noise.


So I tried the wifi hotspot on my phone and it still remained stuck after the clicking and focusing in the head. No movement on the gantry arm. Just now I tried connecting the GF to a different router that I hadn’t used since the first month or so of having it. That router is located next to the modem which is across the house. I was a bit iffy about it being a wifi issue as the “iPhone hotspot” ran into the same issue. The only time the issue was resolved was when I opened up the UI on my phone which made me think it wasn’t a cable issue.

Instead of having the router right next to the unit I might just place it in the hallway just outside of the room just incase. What frustrates me is that everything was working fine up until this point. I never had any connectivity issues. I also haven’t noticed any flickering or flashing of the cabin lights which was a tall tale sign of a cable issue for other users facing this issue. All of the cables seem to be in place. The only time I really go near the cables is when I am cleaning the lid. Which even then I am super careful not to be “rough” with them.

Also I figured I should add that my “hotspot” on my phone uses the wifi network connected to the phone to provide a hotspot. I just tried using the hotspot without my phone being connected to wifi and it didn’t work. SOoooooo I feel like that is a double negative. If the router is shooting off too low of a signal, wouldn’t my phone just be rebroadcasting that low signal? lol

Every device has a different antenna, a different WiFi chipset, a different set of software bugs, etc. And you never know what kind of interference is going on. I had a wireless speaker in the shower that would cut out in the middle of my morning podcast almost every day. I eventually realized that this coincided with another household member getting up and microwaving their breakfast.

That’s why it’s such a pain in the butt to troubleshoot. I wish Glowforge had included some kind of diagnostics on the machine – a screen would be nice, but even if the light just flashed different colors to indicate “searching for WiFi”, “connecting”, etc., it would make it easier to distinguish between not being able to get online vs. not being able to take a picture. Of course, a wired ethernet connection would be ideal, but that horse has been through enough.


OH MY GOD! you literally took the words out of my mouth. I was going to say “man it would be nice if the GF had an ethernet port, then I could just run a hard line from the modem directly to the laser.” But yeah I agree with you, I wish the diagnostic end of it was more accessible to us peasant folk rather than having to wait for the laser gods to read the scrolls of time. I am just praying that I can get some type of response from a team member within the day. Black Friday is coming up and with christmas just around the corner I cannot afford to have any down time with the laser. I only have one so if it goes out, im screwed.

Not to add to your frustration, but the Black Cable has pretty fragile wires that can crack but occasionally line up and when that happens they work fine…and then they don’t when the joint shifts. The only sure answer is the Mother Ship logs. Having a spare black cable handy when you get confirmation can help a lot, though replacing one is very difficult (or it was for me).

I have some experience with ribbon cables, however I feel that this cable given the adhesive areas may be a bit difficult to seat a new one. I have been fairly gentle with the main ribbon cable I don’t even open the lid all the way, max at 45 degree angle to keep the wear and tear to a minimum. I have had my GF for about 6 months and have NEVER had this issue before. It double be the ribbon cable, but given my past experience with ribbon cables, there are normally some precursors that give rise to the failing cable. IE: flickering lights, functionality being on and off, but never just completely off out of the blue, especially with the extra care I have given to that exposed ribbon cable. Can you explain your experience with installing the new cable so I know what to look out for?

I had mine running great for almost two years, and suddenly had an intermittent “failure to center” issue, that became permanent. I suspected the Black cable and ordered one before hearing back from support that it indeed was the issue, so saved a couple days shipping time.

The black cable is in a very awkward place to get at and the adhesive they use could hold the world up. Plus I am disabled in a power chair so it was more awkward for that, and thanks to covid I was unable to get my new glasses so could not see well either… The effort of trying also made my hand shake so I had only a few minutes at a time that I could accomplish anything.

As a result it took me about two weeks to replace the cable. In the end I had to reseat the connections twice which after the cable is glued is extra pain, but though they do not say to do so I fastened all three points before removing the tape on the adhesive, as I had no wish to see one be too short to reach. Getting the tape off at that time is also a problem but I reckoned it would be the lesser one, As a result the cable is a bit crooked but surviving but the main and right side did not seat properly so did not work when powered up. I thought the right side was superfluous as I could live with the lights not working there, but apparently the sensor if the lid is open is also there so it has to be good also. That it eventually worked I am still amazed as I was sure I had broken a wire with al the shoving and twisting,

I actually just ordered two black cables from the shop didn’t even realize that was an option. So hopefully they arrive soon so I can get back to cutting.

1 Like

I should have ordered two and saved the shipping, I was beating myself up thinking I might need two to get one right. Having an extra on hand is good Murphy repellant.

1 Like

Hi @forestmbrown - I wanted to follow up here as I’d just come across this forum ticket and we’ve already connected via email.

I think ordering a replacement cable was the right step here, and should have you back up and running after that cable is replaced.

I’m going to go ahead and close this topic up, please feel free to follow up in our email thread if you have any other questions or concerns.