Introducing Snapmark (September 2018)


#1132

Did you clean the camera lens on the bottom of the head?

The DPI you listed won’t be of much help - what version of Inkscape are you using? They had a fundamental shift a couple versions back in the way things are scaled (that broke a lot of files for people).


#1133

I cleaned both lenses on the bottom of the head. I am using version 92.3.


#1134

Hi @jhileman, taking a quick look at the log from your last run, it doesn’t look like the Snapmarks in the template is set to the correct size (it’s opening as 0.322" x 0.393" for me, the template size is W0.332" x H0.405")


#1135

I tried fixing that and still nothing. I even tried downloading the original template from the website onto a computer without inkscape and still nothing.


#1136

Hi All,
I use Coreldraw for my design so maybe this is a path issue but hey. I Downloaded the snapmarks template etc as described and resized to the stated size and locked them in a layer. I’ve attempted to use the snapmarks feature 8 times so far with no luck. I placed my snapmarks from 6" - 12" apart and even tried 3 sets of them in the design in one print! I increased the contrast of the snapmarks.
It scans, says ready for print but doesn’t move the design to the correct location. In one print it started the engrave 6" to the right of the design! I’m obviously missing something here having followed all of the tutorials and instructions. I have cleaned all lenses, restarted the machine and browser app. I’m all out of ideas.
If only we had a zero reference point for the laser head and a XY grid to reference our design to it would be a lot easier.
Do I give up with snapmarks or is it possible to get it to work without burning through $$ of material?
Any help would be appreciated.


#1137

@bonny will probably want to have the team take a look at it. (From the description of the 6" variance.)


#1138

On another note, when it scans for snapmarks for the first time, the head positions itself slightly off center to the bed. If I cancel the print , change the artwork from ignore to engrave fr example and then scan again for snapmarks, the head tracks to the farthest right and grinds itself against the side wall!


#1139

Yeah, that’s definitely something we saw on a couple of machines in early testing. I think it’s something they have to fix on their end. Sit tight until you hear from @bonny.


#1140

Thanks you!


#1141

@jhileman, can you pull a couple of shots of your Inkscape settings?

  1. First what version of the program are you running? (Check at Help > About Inkscape).
  2. Next…I’d be interested in seeing a screenshot of your Bitmap Preferences settings…

Go to Edit > Preferences > Input/Output > Bitmaps and take a screen shot of the settings.

If they are different from the settings showing below, you can try these and see if things start sizing correctly for you. If that doesn’t work, you can set them back to what you had from the Screen shot.


#1142

Hi
I use CorelDraw, I save all my files as .SVG


#1143

I use CorelDraw as well and have been successful with using Snapmarks so it’s not simply because you’re using CD.


#1144

I’m using version .93.2

I had different settings.

I changed them to your setting and still nothing. I don’t think its inkscape (or at least only inkscape) because I can’t even get the original file to work.


#1145

Hmmmm…it still might be that version of Inkscape. Other folks have had issues since they made whatever changes to Inkscape in that last release.

If you would be willing to uninstall that version and try re-installing the 0.92.1 version (which is what I’m using now and it’s okay) it might work for you. Any time there’s an upgrade it can mess up how Glowforge interprets the file, and it takes them time to track down what happened. (And that’s why I never immediately upgrade when one of these programs rolls one out.)


#1146

While that’s my general approach too, make sure you update Chrome if you use it - they’ve got a hot patch out there for a zero-day exploit. Unlike most Chrome updates this one requires you to relaunch Chrome so if you’re used to it staying updated in the background and haven’t restarted it you won’t have the exploit fix.


#1147

that’s why, with all the rigamarole that has surrounded SVG problems, especially in inkscape, i regularly recommend PDFs.


#1148

My computer is pretty locked down (in a school) so I’ll try it at home over the weekend to create a file in .92.1 and see if that makes a difference.


#1149

Me too. In the early days there were a lot of limitations in Glowforge’s PDF support but these days most of those are fixed and it’s so nice not having to worry about DPI issues.


#1150

and it’s very software independent. it does sometimes create larger files, but i just find it’s more consistent.


#1151

FWIW, I use Snapmarks with CorelDraw without issues. I am exporting to PDF more often than SVG these days, though. I had a run of SVGs that just didn’t work and, never sorted out exactly why since switching to PDF got around it.