Is there nobody in charge at Glowforge?

So I have been having issues with my Set Focus failing every time I use it. So I have tried to calibrate the camera it it fails every time as well.

These are the error messages;

When I try to Set Focus
An error occurred on your Glowforge. Please refresh your browser before printing. It may also help to turn your Glowforge off and then on again.

When I try to Calibrate
WiFi Disconnected
Your Glowforge lost its WiFi connection during the calibration and wasn’t able to reconnect. Move your Glowforge closer to your WiFi antenna, turn it off and on again, then try again with a new piece of material.

I have tried to call for help, no one answers and the email help arrives after I become so frustrated I move to something else.

So today I called Sales and left a message. After several hours a nice young lady called me. When I expressed my frustrations and disappointment with the Glowforge she suggested I send in an email request for support. Apparently, she had forgotten I had told her the email support was not adequate.

After several minutes she suggested I use “firm” verbiage in my email and that would get a response. Hummmm… really? Then I asked her who is in charge of support and her response was “no one”. What? No One is in charge, is said. So I asked who her boss was and she said, Ok. So I replied with, “Ok is not an answer, my question is who is your Boss?” She replied, Eric. I said, "How do I email Eric I asked? And her response was, “I don’t know.” At that point I realized that she was struggling with the truth so I wished her well and hung up.

Seems to me Glowforge is having issues, not only with the hardware and software but the personnel as well.

I understand this is an extremely complex package, however ignoring the customer base and holding them at arms length by only responding by email is not a way to stay in business!

My shop is pristine, my Glowforge is pristine, my wi-fi is 17 feet from the Glowforge, I have reset the wi-fi set up, reset the Glowforge, removed, inspected and reinstalled the print head connections, changed browsers and still have the same issues.

I have looked though all of the community support pages and have tried the advise posted there.

So, if I can’t get this thing working does Glowforge have a buy back program? How do I get a refund on my Proofgrade Materials? How do I get a refund on my Premium Account?

My verbiage can be much “firmer” - I am hoping it does not need to. Please feel free to contact me.

Ron Cole

Your frustration is understandable, but Glowforge personnel do not monitor this forum. Your post is being read by other users. Emails to support is the only way to get hep from Support.


Thanks, I am hoping other users that have been frustrated for months with read this and use “firm” verbiage with support!

Have a great Easter!

1 Like

As a long time user, your problems sound like wifi issues - the lid camera calibration needs a stable connection to complete. It is a long shot, but you could try setting up your Glowforge using your phone as a hotspot rather than using your home wifi. Also, if you contact Glowforge support, you should receive an auto responsse within 24 hours and actual help within a day or two.


Support has been very responsive lately. Using the official support contact form (NOT email!!!) is the way to go.


Yes, the form that creates and email that goes to in which they reply with an email that says, “send me a photo and then we can look at it further” is that the form you are talking about?

Email support that takes several hours or longer on issues that I have already done substantial work to diagnose is not very helpful.

I am not a newbie, I am not technologically challenged - I simply need someone that is an expert with the hardware to speak with. I sure the issue could be resolved quickly.

Thank you for your input.

But is not nothing which would be worse and, it’s how they’ve set up their SOP. It is what it is and years of complaining hasn’t changed it. At least they aren’t up to 2 weeks behind like they used to get during Christmas season and if they are responding in a few hours, standard uses to be a few days not that long ago.

All customer service has to assume the lowest common denominator and follow their script. Everyone should know this by now. If they don’t do the script, they get in trouble and something “stupid” could be missed by a non skilled person answering from pride or misguided notions of delusions of grandeur.

We’ve all wished they were faster and less corporate. At least it seems we have the faster part.


There is no support via phone and never has been :slightly_frowning_face:.

The email support can be quite slow, they do always come through in the end.

1 Like

If there is no telephone support and there never has been, then why in the world would they have a phone number on their website showing a tech support number?

I also understand the “follow the script” mentality, however have a Tier Two and Tier Three support. Even Apple and MicroSoft have that available.

There is just no excuse for poor customer support! Even if it “has never been good but getting better” that is just weak.

I wish I had done a better job doing my research before the purchase. I don’t need help often but when I do a day or week is not acceptable.

1 Like

By the way… I have a GlowForge for sale. Super clean, just some minor software issues I’ve been promised will be fixed. $2000 plus shipping and it’s yours. Let me know.

Not exactly. The form fills in the essential info needed to create a ticket which then generates an email response. If you simply send an email, a person has to sift thru it and create the ticket manually. So the form saves time.

1 Like

You are missing my point. I use the form to create a ticket that captures all of the essential information that generates an email that goes to a support bot that sends a confirmation that goes into a support queue that then gets assigned to a support person that then responds to me with a request for photos 30 minutes before they close.

My point is email support vs telephone support.

I have lost the entire weekend using the GlowForge because the email support asked for unnecessary photos at 4:30pm on Friday. Whereas an expert on the phone could help be find and diagnose the problem in 10-15 minutes.

1 Like

Can you successfully cut items if you input a thickness manually? The set focus tool is quite helpful for aligning artwork, but many of us used our machines for years before this tool became available. Also, try using the hotspot to see if the problems you are having are related to interference with your wifi.


Yes, I can cut by using the manual settings.

I did try your suggestion with the hotspot last night and it failed as well.

Thank you for your help!

OK, from your short details here I suspect you do have an issue with YOUR wifi, not the glowforge.

  1. Make sure your router is using 2.4GHZ wifi and has a unique name for the 2.4Ghz channel.

  2. Make sure you don’t have anything like a microwave lurking close by

  3. Check the camera does not have any muck on the lens, give it a clean.

  4. Repeat for the main laser lens and the two little windows on the bottom of the print head.

The reason I suspect your wifi rather than the glowforge is because the GF end is really simple and will typically either work solid, or fail completely.

Also, for the set focus and calibrate options it is very dependent upon the wifi - AND YOUR INTERNET CONNECTION - being on the whole time. Is it possible you have a glitchy internet connection?

Cutting and the camera uploads and so on are much less sensitive to the internet disconnecting momentarily.

BTW I used the set focus and calibrate exactly once in my ownership of multiple GF units. If things are cutting then just carry on.


Hi sqw,

I set up a 2.4GHZ wifi for the Glowforge called glowforge.
No other items between the router and the Glowforge except the computer.
Camera lens is clean.
Main laser output, incoming lens and two bottom windows lens are clean.

Still failed.

I then setup the Glowforge with my phone as a hotspot for it - Still failed.

Thanks for your suggestions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.