ISO Help with images disappearing when transferred to Glowforge interface

Hi Everyone,
I’ve been talking with Glowforge support and we seem to not be able to figure out the issue. I have always created my SVGs the same way, and recently they haven’t been transferring to the glowforge interface correctly.

Problem: When I make image ornaments or magnets, I edit the image on Photoshop then bring it into Illustrator. I add the cut line on illustrator and then export to an SVG. Recently, when I put the file into glowforge the image disappears and I only see the cut lines.

Troubleshooting: I’ve tried different images, different SVG settings, non-Photoshopped photos, photoshopped photos in different ways, different image files, double checked clipping paths, etc. and each time the photos disappear.

For example, I made this file:
student work (3.3 MB)
student work AGAIN-1

(long story short, my students won a prize to get things made for them… here you see a South Park engraving and two name tags).

As you can see there is only a RED rectangle for where the South Park image would be (it’s visible in the AI format). When I upload it to Glowforge, I can only select options for the cut lines and the photos are gone.

Here is another example: These were image ornaments for Mothers day that I can’t get to work either. The file looks perfect, images are set, and outlines done. When I bring it into Glowforge–the images disappear–and this is the outline view.

Thank you in advance! It’s sort of deflating that all of a sudden my go to process isn’t working. I’m also using this illustrator:

Have you tried pdf instead of svg?


Care to share the svg version to see if someone can help?

How are you exporting the ai version? Do your files contain clip paths?

1 Like

Hi! Let me see if this works. Every time I upload the SVG it adds as an image.

This is the ornament file as an svg uploaded to google drive: Lori-HalfOrnaments.svg - Google Drive

I usually export on Illustrator following the screen shot below but with decimal 1. I tried decimal 5 and it still didn’t work when troubleshooting with Glowforge’s tech support.

The file uploads like something with a clip path - meaning no image, just the outline. I don’t get the clip path error message, however.

Yes that was happening to me too! I’m completely stumped.

Can you share one of the photos from Photoshop before it goes to AI?

Gonna try and see what shows up in inkscape

this is your solution. saving as PDF imports fine. not sure why the SVG is not working. copy/paste isn’t working either. but whenever i have issues with an image in copy/paste, saving as PDF fixes the issue.


i looked, i couldn’t find any clipping path in AI.

Thank YOU! Going to try this and get back to you. It’s been a busy work week, but I wanted to make sure you knew that I saw this!

1 Like

I downloaded your file and opened it in AI, I did find some clipped paths
I just opened the clip group then turned off that layer by clicking the Eye on the left. then deleted the 2 clipping paths did a save as SVG and it uploaded into the GF interface and all was good. I also tried to export as SVG but that did not work. hope this helps a little.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.