I've had my Glowforge for a week and it's been able to power on twice

I was stoked to receive my basic within 5 days of ordering especially since GF markets that the basic is on a month backorder.

I powered it on with no issues last Saturday to connect to wifi. This week I’ve been busy and haven’t had time to try it out since last night. I spent 30+ minutes troubleshooting until it finally powered on and did a test cut that went perfectly(with a tip from the community, please read on). Tonight, I’ve had time to cut and again, but it won’t power on. Here is what I’ve tried:

  • All outlets seem to be in working order and have power access when plugged in
  • I’ve tried various outlets with the machine and it still won’t turn on
  • The power cable does work, I tried it with another electronic
  • The lid is completely closed, but someone suggested I toggle with the light sensor - this seemed to do the trick last night but hasn’t helped tonight

Any suggestions or help is super appreciative. I’m a graphic designer and I’d love to be able to cut out these designs I’ve been sitting on for months. :sweat_smile:

One of the things that you might be able to check is whether the circuit is overloaded. (That can be a little bit tricky, depending on how the house is wired. We had to use a separate circuit just for the Glowforge, since the other circuit in the office has a lot of devices on it.)

If you have a lot of devices on the same circuit, it might not fire up. I can’t remember how many amps it pulls, but it should be listed in the technical specs.

(800W peak)

I believe the two outlets in the room I’m using are tied to the same circuit. The only things I have plugged in at the moment is my wifi modem, a small lamp and my GF. I don’t really have another place to move the GF but I could potentially move my modem. I wouldn’t think that would be sucking all the power though?

Probably not. (Although I have no idea how much they pull.)

Is it the switch on the back that you are flipping and it is not coming on?

I would hope not 800W worth.

Yes the switch in the back and the lights aren’t firing on, no movement at all.

Well, you might need to wait to hear from support. I can’t think of anything else to try that you haven’t already tested for.

Hope you find it though…good luck!

1 Like

I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.