Just received new Pro today and laser doesn’t work

I just received the Glowforge Pro today and set it up. I tried to print the Gift of Good Measure on light and medium basswood proofgrade and the laser won’t fire. I tried other designs with same issue. The printer head moves and I see a red dot on the material for a brief second. I set the power settings to full and nothing. It looks like the laser strip bulb in the back shows a slight light but I’m not sure if it’s supposed to be bright because I’ve never been able to use the Glowforge (just out of box) lens blue remover is missing the magnet pieces. Please help. I was so excited to receive mothers Glowforge today and super disappointed that it’s not working.

Welcome to the forum.

Can you confirm that you put the lens in correctly (cup side up) and that the mirror is properly seated. Also, when you try to print the Gift of Good Measure, is this what your interface looked like?


The thing is my Glowforge didn’t come with the magnets to remove the lens - just the blue plastic tube. Thanks.

The lens removal tool is not critical for removing the lens. How did you put the lens into the printhead?


It came already installed in the printhead. I have a feeling it was a used lens/Glowforge. The box didn’t come with straps and the printhead was just loose in a separate styrofoam part, not packaged.

If you are trying the gift of good measure on proofgrade you don’t have to enter any settings. The machine will read the bar code and automatically set the correct speed and power for each step.


Set up the Gift of Good Measure and share a photo like mine above showing the settings.


You received it from your mom? Did she have any issues with it prior?

Sorry, it was a typo- I meant to say I received “my” Glowforge today. I just ordered it last week. It looks like support is taking care of the issue.

We can guess and suggest various things to do but you really need to contact Glowforge directly, since they have logs to look at that will narrow the problem down.
Be sure to give them time and date data to make the log easy to find.

1 Like

FYI, the print head is supposed to be loose in a foam block, and the lens is supposed to be preinstalled. It only has a small cylinder of foam you remove underneath it, which keeps the preinstalled lens from being jostled out of the print head during shipping. Those are both normal features of a new Glowforge.


Thanks! Support is taking care of the issue, seems to be electrical.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.