Laser issue

I last used my glowforge last week to engrave a cutting board. it worked like a dream which is usually how it goes. Turned it on today to make a customer order and it acted as though it was working however it did not cut or engrave the design.
SO basically the laser isnt firing?!?
I have cleaned everything and still nothing. Ive tried multiple designs, the gift of glow everything and i cant seem to resolve the issue. HELP! i have customer orders that need to be filled immediately and I cant do that without my forge.

Support can look at your logs from their end - let them know what time you tried the Gift of Good Measure so they can look specifically for that.

In the meantime, if it turns out to be the laser tube or your power you’re going to need to ship it back to get it repaired so for your businesses sake you should find out if there are other laser owners in your area you can farm work out to (either personal owners or a Tech Shop equivalent). You will lose some profit, but still get the work done.

I will have to try it again when I get home tonight and send you a time because I don’t know.
I know I tried it around 330 central time today with the gift of good measure but it wasn’t making any marks just a blank piece of wood again so I stopped it

Double check your setttings…sometimes the power defaults to ‘1’


Hello Sarah! Welcome to the forum. :sunglasses:
My first thought is what Xabbess said.


Hi @sarah.peschong, I see that you also emailed us about this issue and we’ve responded to you there, so I’m going to close this topic.