Laser Not Firing please help

My Glowforge laser is not firing. Lenses and fans are clean. I’ve tried to cut the gift of good measure as well as other simple files on proofgrade material. I’ve rechecked my settings and everything looks good. It will start off great and the button glows normally. When I push the button, the head moves but the laser will not cut or engrave.

Make sure your power hasn’t been accidentally set to 1!

1 Like

I have checked and it is set to full power.

Was this the first time you tried to cut anything or were you successful on something? By the way, welcome to the community!!

1 Like

Thank you! I have cut and engraved many things with my glowforge before. Today I turned it on and it just didn’t cut or engrave. I tried restarting and restting completely. I’ve had no luck.

Sounds like your power supply’s gone kaput. Email if you haven’t already with the same info you shared here and they’ll get you back up and running.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.