Lens Won't Stay In Place

My lens and mirror were damaged so I ordered new ones.

Now, when I install the lens, it seems to be in place but when I turn on the machine, it can not focus and when I remove the head, the lens has fallen out of place (pictured). I have tried numerous times and can not get it to stay.

On the rare occasion it moves past the focusing stage and I can start a cut, the line is super thick (pictured) and when I stop the machine and check the lens, it has fallen out again.

I have only had the machine 2 months and it worked perfectly up until now. So frustrating! Any help is appreciated.

It might not have just been the lens and mirror damaged the first time around…did you take photos of the inside of the head from the top to show to Support the first time? (Remove the top and mirror, and shoot down into the head…there may have been some head damage.)

You definitely don’t want to try to run it like that though. Doesn’t look safe. :neutral_face:

1 Like

I did not take photos like that because the lens was pretty badly damaged so I assumed that was the issue.

After some more research it seems like the lens is not “clicking” into place when installing. It’s almost like there is no magnet pulling it into place anymore.

Yeah, take a photo or two of the interior of the head, without the lens in it, and either send them to Support or post them here…it might be damaged and they need to see it to be able to decide what to do next. :slightly_smiling_face:


Hi there. I’m sorry to see you ran into some trouble with your printer head lens and print mirror. I saw you also created an email ticket for this same issue, and looks like you’ve been working with my fellow team member Raymond. To avoid any miscommunication or confusion, I will close this thread so we can continue the conversation though your other emailed ticket. Thank you!