Lid Opening Replacement Didnt Work

Well, Got the New strip from and reinstalled, Lid Error Still. Didnt work sure hope they replace the machine. 4wks old 5 cuts and now down for 2 of those weeks. Super sad, dissapointed and just plain sad.

1 Like

Whoops! Your luck is less than stellar…it does happen once in a while, but they are very good about replacing the machines if there’s a problem that the user can’t fix so they’ll get back to you as soon as they see your post to make the necessary arrangements to get you back up and running ASAP. (You’re under warranty so no cost to you, but it is a bit of a hassle.)

Sorry to hear it! :frowning:


They are very delicate and tricky to install and I was sure I had broken mine when I installed it. Fortunately, one side was almost but not quite clicked in and it suddenly worked when I got it right. however as easy as they are to mess up just opening the lid too much, they are more easy to do the same while installing a new one. :grimacing:


I did send support pictures after installed it. Haven’t heard from anyone, thank you for responding

Yes very disheartening. Committed to a couple local events so not sure if I’ll be ready because of this. $$ lost

Sorry to hear this. I had similar issues in the past but finally have a machine that’s working great. It was painful to wait but so worth it. Support will get with you soon.

I’m so sorry for the frustration and disappointment after installing the replacement cable and running into the same error.

I’ve reviewed the most recent logs from your Glowforge, and I’ve found that as a next step we should get a replacement sent out to you. I’m going to close this thread, and I’ll be in touch with you very soon via email with next steps.