Machine Frozen and stuck on Cancelling

Hello. Its now been 2 days that my gloforge is stuck on cancelling. The button that normally spins when it is cancelling isnt moving. It looks more like a still image. Ive combed through these topics and done everything that was suggested.

Welcome to the forum - lots of folks here ready to help but “I’ve don everything” won’t do it. Let us know exactly what you’ve done.

My first suggestion is almost always to clear the cache on your browser or try a different browser - and you may have done that, but I can’t be sure.

Let us know and we’re here to help!

Hi. Thanks!!

We’ve cleared the cache and tried a different browser. We also tried the factory reset instructions we found on here. We cleaned it and we also tried holding the print button down while powering the machine on which was suggested by someone here. And it still isnt working

If you’ve done the factory reset then you’ll need to go through the WiFi set up again - hold down the button until it turns teal…like you did when you first got it.

1 Like

You should never perform a factory reset unless directed to by support. It wipes all logs that would have allowed them to diagnose any potential issue.


Fortunately (I guess) it didn’t respond to the factory reset as per my husband

I think the “cancelling” is more of a browser function than a machine function. I would think power-cycling the machine should clear it, even if there is machine involvement. Are you still seeing “cancelling” AFTER restarting the machine AND clearing your cache and restarting your browser?

I can confirm that if a job gets messed up and stuck on canceling, it will show the same on a laptop, or if you switch to an iPad, a phone, etc.

It’s between the machine and the cloud, not local browser. There is no way to “cancel” the cancel process.

It’s especially “sticky” if it’s during a passthrough job!

1 Like

Good to know.

Hi eflyguy

So what’s my next move? I’ve sent an email to gloforge but it’s been 2 days and no response.

Yes- We’ve done all that and it’s still showing cancelling. I appreciate everyone trying to help.

You opened a support ticket when you posted here (and another when you emailed them) so they’ll be along soon. (Just do one or the other in the future, since duplicates slow things down. :slight_smile: )

Hello @21ivyst - I’m sorry to hear about your trouble, and thanks @eflyguy @deirdrebeth and @geek2nurse for jumping in to help.

I’d like to dig into this issue a bit further but I’m having some trouble locating a printer associated with your user account @21ivyst, so I’ve sent a follow up email to confirm some further information from you so I can investigate a bit further .

Please check for that email, and I’ll go ahead and close this topic for now so we can finish via that email thread.