Maximum steps limited by the size of my monitor? Really?

When I maximize my browser window when looking at, I have room for 9 steps down the left side of my screen.

My job has 24 steps. How do I adjust the settings for the 15 steps I can’t see? There doesn’t seem to be a scroll bar or any way to access the steps that are off the bottom of the screen.

This can’t possibly be right? Is it? What am I doing wrong?

If it matters, I’m using Chrome Version 65.0.3325.181



no scroll bar but if hover over left sidebar it will scroll.

1 Like

What browser do you use, brokendrum?

I usually use chrome, whatever the latest version is. I honestly can’t say if mine has a scroll bar, but if I hover to mouse over the list of jobs it let’s me scroll up and down through them using the scrollwheel. That’s with a mouse and not a track pad though, so if you’re using a track pad it might not work the same :sweat_smile:

Aaahh, that’s the keyword I didn’t get from your first reply. While hovering over the area, you then used the scroll function of you mouse to move the list up and down.

I’ll have to go grab another mouse to use.

I normally use a trackball that doesn’t have a scroll function. I tried to hover over and use the arrow keys. But that was a bust too. I know I have suitable mouse around here somewhere.

This UI really needs an overhaul! I can’t believe that I can’t just click on the actual art image on the screen to pull up the settings for that piece.


Yeah, I’m sure it’s in the magical hopper :sweat_smile: I’m glad to hear you have a mouse that should work though!

Someone at Glowforge really hates scrollbars and kills them throughout the interface. Of course this causes no end of problems for people who don’t use an input device with a scroll wheel or scrolling gesture.

It almost certainly causes issues for people using assistive technologies as well.


Thanks all for the feedback – I’m going to send it to our product team with a note that it came from customers.