Ok, so this is our 2nd machine…2nd in less than 3 months time. They replaced the first one because of wiring issues. Set me back at least a month’s of work. It seems everytime I get this thing going and I’m confident that GF is going to be the winner, BAM!!! Here we go again with a MAJOR issue.

My laser is not firing. A tiny, little piece on the wiring tape (from board to laser) fell off and now the tape will not hold in place…got that “kinda” fixed for the moment and NOW my workspace is about HALF of what it was (picture attached). AND, the mechanism keeps jolting on something…I don’t know what. I cleaned it, I observed it, I cleaned it agai


So far all this company and machine has done is cause me a WHOLE lot of heartache, business losses and headaches. Please tell me there’s someway to fix these issues because I’m about to drive to Seattle and throw this machine through their window.

Do you have your speed dialed up high? If so your laser head needs the extra space to slow down and stop and before it can start in the other direction for engrave, thus GF drastically reduces your useable area. Try a low speed 1000 or less and see what happens.

1 Like

I’ve tried high, I’ve tried low, I’ve tried middle…Nothing

That is a bummer. I have not had these issues, so I cannot help more. Good luck.

You can try posting your comments on the Facebook glowforge user group (GUG) they help solve issues there as well.

1 Like

Your speed for that engrave is pretty high. (It shows on the thumbnail.) Reduce the speed to 1000 and you will get much more usable area. Or slide the Engrave in Margin slider in the Manual settings if you want to keep that speed.

I was on my third machine three months in, and was pretty discouraged. Customer service was always patient with me, and some good folks on this forum talked me off the ledge a few times. I’m still on my third machine, and it’s been almost 8 months. Couldn’t be happier with this machine.
I hope support can get you going again soon. Hang in there!


@Jules, I had tried it on multiple different powers, speeds, everything…

But, Someone out there is playing God tonight bc about 4 minutes after I posted this it magically started working perfectly. :woman_shrugging:

So, for now, let’s just all hold our breath and see what happenes.

1 Like

Pictures would help.

It says your speed is 2275 so since the head has to get up tp speed and then slow down before reversing it needs that extra room,

1 Like

Sometimes a dropped signal for a fraction of a sec will just cause the screen to freeze. Glad you got it going again.

@jules has the magic touch…:grin:


Ya think I scared it? :smile:
My hubs has that ability with mechanical things…balky appliances straighten right out the instant he comes through the door! (After I have spent the entire day cussing them and throwing things.)


Lol, I apparently inherited that ability from my dad. Growing up, he worked in the oilfield a week at a time. Without fail, our car, or the a/c, or something would go out as soon as he left. My mother would spend all week trying to fix whatever it was, and would invariably fail. My dad would come home, and she would light into him with a vengeance, taking out her frustrations. Dad would go to see what could be done, and whatever was broke, miraculously began working at his mere presence.
As I’m sure you can imagine, my mother was never grateful…


Read above. For now it’s resolved. But, thank you for your help :slight_smile:

Technician syndrome, I encounter it every day :upside_down_face:


I’m so sorry that you ran into trouble with your replacement unit. Thank you for the update that it’s working as expected now. So that we can take a closer look for anything unusual, would you please send us a couple photos of the part which you described?

We’ll review the photos you send and then follow up with any next steps which are needed.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you run into any other trouble, please either start a new thread or email