Missing black cable installation instructions

Good news: I received the replacement black cable.

However, Support was supposed to also email me instructions for installing the black cable. I have not yet received those instructions.

Another GF user sent the instructions to me.

1 Like

Did the new cable correct your issue? We received and installed our cable and it is still stuck on centering or scanning but the arm never moves. Did all of the recommended troubleshooting suggestions, but still no good. So it seems like we replaced a perfectly good cable with another perfectly good cable for no reason. The odd thing is that this issue started right after the last update which was supposed to improve connectivity to their servers. Wondering if this update actually was what has caused my issues because the timing is uncanny especially the number of recent posts regarding this issue. Not sure exactly how updates are tested prior to rollout or if there is a way to roll back the firmware to an older version to test that the firmware is not what caused the corruption.

There are more than 18,000 Glowforges out there. What would be uncanny is if the update messed up your machine but not thousands of others. :wink: (Correlation <> Causation).


They are tested extensively amongst a large group of owners. The update did not cause your issue. The GF is basically a computer, the updates are “software” but the things that cause your issue are hardware and driver related, which did not change.

Mine turned out being where the cable connects to on the white circuit board. You can check out my post about it:


I was lucky enough to figure out what exactly went wrong after getting my replacement cable so they sent me the part. I had to take my machine apart to get to it, but as I’m out of warranty, it was far better to go that route than paying the hundreds of dollars it would have cost to ship and diagnose.


Thanks for the replies! I understand all of what is being said, but I have written code and worked on machines longer than most have been around to know, and corruption does happen! My wife and I keep our Glowforge immaculate and just turned it on after 2 months and the machine turned off and on like there was an update, let us cut one thing and then stopped. Never opening the lid all the way. So without tearing it apart we are perplexed to what it is. We love Glowforge which is why we waited over 2 years to get one!!! We are just frustrated now.

The GF is Linux-based. Updates are sent using standard OS and App package update processes. Corruption does not happen, updated files are MD5-verified.

You have an almost international problem with shipping so it’s cool that you could get the part. The company doesn’t provide many parts that way. Just curious, did they give you any guidance on how to get at the circuit board? Or was it, “here is the part”.

1 Like

Well I did some detective work and looked around, it’s actually relatively easy to get to once you know what you’re looking for. I followed the cable that connects to it, found that it goes back and around the power supply, and into the main board on the right side. Once I got the glass off, I really only needed to undo the two screws holding the white board to the machine, slide it out from behind the case reinforcement and voila. Support had informed me that it wasn’t a part that they’ve sent out, or at least, not nearly as often as the black cable, but they got me the part regardless. I was really grateful once the ball got moving, because once it did, they got me the part I needed instead of telling me that I had to send my machine in and it is back up and running!

So, no, there were no instructions, but I’d guess that’s do to me doing all the work and the part not typically being identified in the field as being broken.


Thanks for the replies. We will just wait to see if there is anyone that has this issue fixed with the lid cable being replaced. We are just curious because it does seem like it is happening to a lot of owners. Best of luck to everyone.

For everyone who wants to know if the black cable fixed my problem: I haven’t tried it yet.

I found where the break is located in the original black cable and I fixed the connectivity by re-bending the cable. See: Black Cable Hack for Voiding Warranty

The instructions for replacing the cable are straightforward, but the steps are pretty complicated. In particular, there is a lot of double-back tape and you have to be really careful with the alignment. I don’t expect my “re-bend it” solution to work forever, but until it fails, I’d rather get as much life out of the old cable as possible.


I’m so sorry you didn’t get the instructions my colleague Gary sent to you! I am glad you were able to get the instructions from another person. If you run into any trouble during the set up feel free to reach out to us.

@dmc197 We try to keep to one topic per post in the Problems and Support section. Can you create a new post with this question? If you’d prefer, you could instead email us at support@glowforge.com.

At this time I am going to close this thread